aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorhsu <hsu@FreeBSD.org>1995-03-09 18:16:20 +0800
committerhsu <hsu@FreeBSD.org>1995-03-09 18:16:20 +0800
commit93d9dcd2325cd10e38ceef528c1b095300a9f1d1 (patch)
tree1e1d8ea789c84421a05a0c992c774a03455f6cfa /lang
parentdcd7cc98f32b69182d318d9b0b3fb464f25a4812 (diff)
downloadfreebsd-ports-gnome-93d9dcd2325cd10e38ceef528c1b095300a9f1d1.tar.gz
freebsd-ports-gnome-93d9dcd2325cd10e38ceef528c1b095300a9f1d1.tar.zst
freebsd-ports-gnome-93d9dcd2325cd10e38ceef528c1b095300a9f1d1.zip
Elk -- an imbeddable Scheme interpreter
Submitted by: Thomas Gellekum <thomas@ghpc8.ihf.rwth-aachen.de>
Diffstat (limited to 'lang')
-rw-r--r--lang/elk/Makefile28
-rw-r--r--lang/elk/distinfo1
-rw-r--r--lang/elk/pkg-comment1
-rw-r--r--lang/elk/pkg-descr12
-rw-r--r--lang/elk/pkg-plist4
5 files changed, 46 insertions, 0 deletions
diff --git a/lang/elk/Makefile b/lang/elk/Makefile
new file mode 100644
index 000000000000..a0d8e9ccf1dc
--- /dev/null
+++ b/lang/elk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: elk
+# Version required: 2.2
+# Date created: 08 March 1995
+# Whom: thomas@ghpc8.ihf.rwth-aachen.de
+#
+
+DISTNAME= elk-2.2
+MASTER_SITES= ftp://ftp.x.org/contrib/devel_tools
+PATCH_STRIP= -p1
+
+#
+# /usr/local/lib/elk is built into the port.
+# change it in ${WRKSRC}/config/site if you change it here and vice versa.
+#
+
+pre-install:
+ @mkdir -p ${PREFIX}/lib/elk
+
+install: build
+ @echo "===> Installing for ${DISTNAME}"
+ @${MAKE} ${MAKEFLAGS} pre-install
+ @(cd ${WRKSRC}; ${MAKE} PREFIX=${PREFIX} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+ @(cd /usr/local/lib/elk; mv bin/scheme ${PREFIX}/bin; \
+ mkdir -p ${PREFIX}/include/elk; mv include/*.h ${PREFIX}/include/elk; \
+ rmdir bin include)
+ @${TOUCH} ${TOUCH_FLAGS} ${INSTALL_COOKIE}
+
+.include <bsd.port.mk>
diff --git a/lang/elk/distinfo b/lang/elk/distinfo
new file mode 100644
index 000000000000..66f2abaf9acf
--- /dev/null
+++ b/lang/elk/distinfo
@@ -0,0 +1 @@
+MD5 (elk-2.2.tar.gz) = 3ce58fb4332959c840e998a5ed150e73
diff --git a/lang/elk/pkg-comment b/lang/elk/pkg-comment
new file mode 100644
index 000000000000..2e82be98fd8a
--- /dev/null
+++ b/lang/elk/pkg-comment
@@ -0,0 +1 @@
+Elk -- an imbeddable Scheme interpreter
diff --git a/lang/elk/pkg-descr b/lang/elk/pkg-descr
new file mode 100644
index 000000000000..7ff477a1ed4e
--- /dev/null
+++ b/lang/elk/pkg-descr
@@ -0,0 +1,12 @@
+This is release 2.2 of Elk, the Extension Language Kit.
+
+Elk is a Scheme interpreter intended to be used as a general, reusable
+extension language subsystem for integration into existing and future
+applications. Elk can also be used as a stand-alone implementation of
+the Scheme programming language.
+
+One purpose of the Elk project is to end the recent proliferation of
+mutually incompatible Lisp-like extension languages. Instead of
+inventing and implementing yet another extension language, application
+programmers can integrate Elk into their application to make it
+extensible and highly customizable.
diff --git a/lang/elk/pkg-plist b/lang/elk/pkg-plist
new file mode 100644
index 000000000000..964b561c2208
--- /dev/null
+++ b/lang/elk/pkg-plist
@@ -0,0 +1,4 @@
+@cwd /usr/local
+bin/scheme
+lib/elk
+include/elk