aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-15 19:13:51 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-15 19:13:51 +0800
commit9a00380834c59e9495f411f44e5f7e77e9efae72 (patch)
treedc247a8b3febb655c48ebf7d68e840d7b631d386 /lang
parent55fde4afa4572b062d646703ee5e5758768c3f48 (diff)
downloadfreebsd-ports-gnome-9a00380834c59e9495f411f44e5f7e77e9efae72.tar.gz
freebsd-ports-gnome-9a00380834c59e9495f411f44e5f7e77e9efae72.tar.zst
freebsd-ports-gnome-9a00380834c59e9495f411f44e5f7e77e9efae72.zip
Precompile the asdf-install module.
Remove .orig files after patching. Set MANUAL_PACKAGE_BUILD due to the SSE2 instruction set requirement.
Diffstat (limited to 'lang')
-rw-r--r--lang/ccl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/ccl/Makefile b/lang/ccl/Makefile
index ff8c644a8c63..fd608e43b8ca 100644
--- a/lang/ccl/Makefile
+++ b/lang/ccl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ccl
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang lisp
MASTER_SITES= ftp://ftp.clozure.com/pub/release/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsdx86
@@ -19,6 +19,8 @@ WRKSRC= ${WRKDIR}/ccl
ONLY_FOR_ARCHS= i386 amd64
+MANUAL_PACKAGE_BUILD=yes
+
CCL_DIRECTORY= ${PREFIX}/lib/ccl
CCL_PLIST= ${WRKDIR}/pkg-plist
# the following files will not be installed
@@ -41,7 +43,8 @@ SUB_FILES= ccl.sh
post-patch:
@${SED} -i '' -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/tools/asdf.lisp
- @${FIND} ${WRKSRC} -name .svn -or -name .cvsignore | ${XARGS} ${RM} -r -f
+ @${FIND} ${WRKSRC} -name .svn -or -name .cvsignore -or -name "*.orig" \
+ | ${XARGS} ${RM} -r -f
do-build:
@${RM} -f ${WRKSRC}/fx86cl ${WRKSRC}/fx86cl64
@@ -52,6 +55,8 @@ do-build:
fi
@cd ${WRKSRC} && ${ECHO_CMD} | ./${FX86CL} --no-init --batch --quiet \
--eval "(ccl:rebuild-ccl :full t)" \
+ --eval "(require 'asdf)" \
+ --eval "(asdf:operate 'asdf:load-op 'asdf-install)" \
--eval "(quit)"
do-install: