aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-10-15 00:58:48 +0800
committerMikael Urankar <mikael@FreeBSD.org>2020-10-15 00:58:48 +0800
commit9afa07826e0e42609bf4c97c250acd694d7bfe71 (patch)
treec9cd9b2850f1aaa427ef9336c93aa802b2703900 /lang
parent84fe90812ca78091124402f1df26d214c71daee3 (diff)
downloadfreebsd-ports-gnome-9afa07826e0e42609bf4c97c250acd694d7bfe71.tar.gz
freebsd-ports-gnome-9afa07826e0e42609bf4c97c250acd694d7bfe71.tar.zst
freebsd-ports-gnome-9afa07826e0e42609bf4c97c250acd694d7bfe71.zip
lang/rust: restore REINPLACE_CMD for ppc64-elfv1
This patch is needed for ppc64-elfv1 and we don't build rust-nightly on tier2 arch Reported by: ashish
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 0205fb9b8b00..0d49ff305759 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -177,6 +177,12 @@ do-configure:
.endif
@${REINPLACE_CMD} 's,%CC%,${CC},g' \
${WRKSRC}/src/bootstrap/native.rs
+# src/librustc_llvm has moved to compiler/rustc_llvm in nightly
+# this reinplace_cmd is used for ppc64-elfv1
+.if !defined(NIGHTLY_DATE)
+ @${REINPLACE_CMD} 's,%CC%,${CC},g' \
+ ${WRKSRC}/src/librustc_llvm/build.rs
+.endif
do-build:
@cd ${WRKSRC} && \