aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-05-21 04:09:54 +0800
committerolgeni <olgeni@FreeBSD.org>2015-05-21 04:09:54 +0800
commit9ca3aba82c17ec7f6dc2d5fdf3f3e78f8af10048 (patch)
tree0725af1ed2e803898ecfe90621d5f03576e4fba6 /lang
parent300d2af19c387578f1ad31dc0628e98d9973b1d2 (diff)
downloadfreebsd-ports-gnome-9ca3aba82c17ec7f6dc2d5fdf3f3e78f8af10048.tar.gz
freebsd-ports-gnome-9ca3aba82c17ec7f6dc2d5fdf3f3e78f8af10048.tar.zst
freebsd-ports-gnome-9ca3aba82c17ec7f6dc2d5fdf3f3e78f8af10048.zip
Unbreak build on armv6.
PR: 200322 Submitted by: a.andersson.thn@gmail.com
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime17/Makefile4
-rw-r--r--lang/erlang/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index cf4972e50542..ed47ccf26b00 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -151,6 +151,10 @@ CONFIGURE_ARGS+=--disable-smp-support
MAKE_ARGS+= ARCH=x86
.endif
+.if ${ARCH} == armv6
+MAKE_ARGS+= ARCH=arm
+.endif
+
# The man-pages are put (in spite of FreeBSD's port convention) in a private
# subdir. This is to avoid cluttering up the man page name space. Also the
# Erlang man pages are more of internal documentation using the man format than
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index ea6423ce287c..64bfeb3e9f8c 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -168,6 +168,10 @@ CONFIGURE_ARGS+=--disable-smp-support
MAKE_ARGS+= ARCH=x86
.endif
+.if ${ARCH} == armv6
+MAKE_ARGS+= ARCH=arm
+.endif
+
# The man-pages are put (in spite of FreeBSD's port convention) in a private
# subdir. This is to avoid cluttering up the man page name space. Also the
# Erlang man pages are more of internal documentation using the man format than