aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-09-13 07:20:43 +0800
committergerald <gerald@FreeBSD.org>2012-09-13 07:20:43 +0800
commit9edd5dbf941f92285a027f188812c22b99b4f3ab (patch)
tree0425f26397b934ade5b2c8ad993e761535a9adda /lang
parentc10ccacf557417d91b60bbb602e9a9907ff76c3f (diff)
downloadfreebsd-ports-gnome-9edd5dbf941f92285a027f188812c22b99b4f3ab.tar.gz
freebsd-ports-gnome-9edd5dbf941f92285a027f188812c22b99b4f3ab.tar.zst
freebsd-ports-gnome-9edd5dbf941f92285a027f188812c22b99b4f3ab.zip
Just build, do not bootstrap, this version of GCC in our ports tree.
This speeds up a full port/package test cycle by 50% on a 4-core system; a simple build/install will benefit even more. On the way, have he compiler report itself as "FreeBSD Ports Collection".
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc42/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index 7b45a26b389d..d8822aead12a 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -51,7 +51,8 @@ WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-nls \
+CONFIGURE_ARGS+=--disable-bootstrap \
+ --disable-nls \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
--program-suffix=${SUFFIX} \
@@ -60,9 +61,9 @@ CONFIGURE_ARGS+=--disable-nls \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--with-ld=/usr/bin/ld \
--with-libiconv-prefix=${LOCALBASE} \
+ --with-pkgversion="FreeBSD Ports Collection" \
--with-system-zlib
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
PLIST_SUB= GCC_VER=${PORTVERSION:C/(.+)\.[0-9]+/\1/} \
GNU_HOST=${CONFIGURE_TARGET} \