aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-11-28 00:40:33 +0800
committerlinimon <linimon@FreeBSD.org>2018-11-28 00:40:33 +0800
commita22c4ff92c3b657b9b5328ea0a4b14aba4e95402 (patch)
treeb7dec919c5347f740110c9c674f29238b97a2650 /lang
parent4e663971632a3c1b2cc6739f6a56c874dba0e421 (diff)
downloadfreebsd-ports-gnome-a22c4ff92c3b657b9b5328ea0a4b14aba4e95402.tar.gz
freebsd-ports-gnome-a22c4ff92c3b657b9b5328ea0a4b14aba4e95402.tar.zst
freebsd-ports-gnome-a22c4ff92c3b657b9b5328ea0a4b14aba4e95402.zip
Switch the libstdc++ flag to be dependent on an existance test. This
will be more robust if the quoted archs switch to libc++ in the future. Reported by: jbeich Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/libobjc2/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index e116b80ef1b2..a38e6f998eba 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -29,12 +29,9 @@ CMAKE_ARGS+= -DTESTS=OFF
# This shouldn't be needed, but our llvm port installs llvm-config with a silly
# name...
CMAKE_ARGS+= -DLLVM_OPTS=OFF
-CXXFLAGS_powerpc64= -stdlib=libstdc++
-CXXFLAGS_powerpcspe= -stdlib=libstdc++
-CXXFLAGS_powerpc= -stdlib=libstdc++
-CXXFLAGS_sparc64= -stdlib=libstdc++
-CXXFLAGS_mips= -stdlib=libstdc++
-CXXFLAGS_mips64= -stdlib=libstdc++
+.if exists(/usr/lib/libstdc++.so)
+CXXFLAGS+= -stdlib=libstdc++
+.endif
post-install:
${LN} -sf libobjc.so.${SHLIB_MAJOR}.${SHLIB_MINOR} ${STAGEDIR}${PREFIX}/lib/libobjc.so.${SHLIB_MAJOR}