aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2014-05-27 05:11:38 +0800
committergerald <gerald@FreeBSD.org>2014-05-27 05:11:38 +0800
commitaab95d3ee26cca5c369beed216d327d4644f088b (patch)
tree73c70c1f9e93062df0adf91ee89993b9d54469ad /lang
parent77892ec7ea2ebb6e1af0a7df542b71da7a981899 (diff)
downloadfreebsd-ports-gnome-aab95d3ee26cca5c369beed216d327d4644f088b.tar.gz
freebsd-ports-gnome-aab95d3ee26cca5c369beed216d327d4644f088b.tar.zst
freebsd-ports-gnome-aab95d3ee26cca5c369beed216d327d4644f088b.zip
On amd64 systems with clang, we still need to build with GCC for the time
being since clang pretends it is GCC, but cannot cope with all GCC specific input. Reported by: Andrzej Tobola <ato@iem.pw.edu.pl> Tested with: redports
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc410/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/lang/gcc410/Makefile b/lang/gcc410/Makefile
index fb1c40b98c5d..4d8aba769ea5 100644
--- a/lang/gcc410/Makefile
+++ b/lang/gcc410/Makefile
@@ -33,6 +33,9 @@ GCC_VERSION= ${PORTVERSION:C/(.+)\.s[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
USES= gmake iconv perl5 tar:bzip2
+.if exists(/usr/bin/clang) && ${ARCH} == "amd64"
+USE_GCC= yes
+.endif
USE_BINUTILS= yes
USE_PERL5= build
SSP_UNSAFE= yes