aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-02-24 17:43:35 +0800
committervd <vd@FreeBSD.org>2006-02-24 17:43:35 +0800
commitb767d4ed23723882fb631c16404bc3e1c028dca1 (patch)
treebd610c7571f826cfca9277ebfab0d848a12f06be /lang
parente0bab13f8dec076250a72b4a5e889c2605a48530 (diff)
downloadfreebsd-ports-gnome-b767d4ed23723882fb631c16404bc3e1c028dca1.tar.gz
freebsd-ports-gnome-b767d4ed23723882fb631c16404bc3e1c028dca1.tar.zst
freebsd-ports-gnome-b767d4ed23723882fb631c16404bc3e1c028dca1.zip
Unbreak by forcing the dxl module to build (and therefore install and
not cause plist problems at deinstall stage) Approved by: portmgr (linimon), garga (mentor, implicitly)
Diffstat (limited to 'lang')
-rw-r--r--lang/q/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/q/Makefile b/lang/q/Makefile
index 7e72954043fe..b20568c3b11d 100644
--- a/lang/q/Makefile
+++ b/lang/q/Makefile
@@ -24,8 +24,6 @@ LIB_DEPENDS= Magick.9:${PORTSDIR}/graphics/ImageMagick \
gmp.6:${PORTSDIR}/math/libgmp4 \
curl:${PORTSDIR}/ftp/curl
-BROKEN= Incorrect pkg-plist
-
USE_REINPLACE= yes
USE_BISON= yes
USE_GNOME= gnometarget libxml2 libxslt
@@ -34,7 +32,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${LOCALBASE}/dx/lib_freebsd ${PTHREAD_LIBS}" \
CPPFLAGS="${PTHREAD_CFLAGS}" \
MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --with-dxl-includes=-I${LOCALBASE}/dx/include
+# we need to add -lDX, because there is undefined reference to _dxfImportBin_FP
+# in libDXL.so (_dxfImportBin_FP is defined in libDX.so)
+CONFIGURE_ARGS= --with-dxl-includes=-I${LOCALBASE}/dx/include \
+ "--with-dxl=-lDXL -lDX"
INSTALLS_SHLIB= yes
# The tk module is built by default, but you can disable this by defining