aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-01-31 00:10:57 +0800
committerale <ale@FreeBSD.org>2006-01-31 00:10:57 +0800
commitbbfdfa481756e2983dbf7f4a2257fb22018d39d4 (patch)
treebb7f5c579163ba888257ac99915ade9559067626 /lang
parentdf3a7daf84544a6c1832e7af363891136a63fc92 (diff)
downloadfreebsd-ports-gnome-bbfdfa481756e2983dbf7f4a2257fb22018d39d4.tar.gz
freebsd-ports-gnome-bbfdfa481756e2983dbf7f4a2257fb22018d39d4.tar.zst
freebsd-ports-gnome-bbfdfa481756e2983dbf7f4a2257fb22018d39d4.zip
Add support for getopt_long and fix getopt().
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile3
-rw-r--r--lang/php5/files/patch-ext_standard_basic_functions.c10
-rw-r--r--lang/php53/Makefile3
-rw-r--r--lang/php53/files/patch-ext_standard_basic_functions.c10
4 files changed, 24 insertions, 2 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index c3edd2427f86..4e33af8a9dca 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.1.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -25,6 +25,7 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} == "-cgi" || ${PKGNAMESUFFIX} == "-cli"
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
diff --git a/lang/php5/files/patch-ext_standard_basic_functions.c b/lang/php5/files/patch-ext_standard_basic_functions.c
new file mode 100644
index 000000000000..ffb8970fdc80
--- /dev/null
+++ b/lang/php5/files/patch-ext_standard_basic_functions.c
@@ -0,0 +1,10 @@
+--- ext/standard/basic_functions.c.orig Mon Jan 30 16:58:56 2006
++++ ext/standard/basic_functions.c Mon Jan 30 16:59:13 2006
+@@ -78,6 +78,7 @@
+ # include <sys/mman.h>
+ #endif
+
++#define HARTMUT_0
+ #ifdef HARTMUT_0
+ #include <getopt.h>
+ #endif
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index c3edd2427f86..4e33af8a9dca 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php5
PORTVERSION= 5.1.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -25,6 +25,7 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} == "-cgi" || ${PKGNAMESUFFIX} == "-cli"
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
diff --git a/lang/php53/files/patch-ext_standard_basic_functions.c b/lang/php53/files/patch-ext_standard_basic_functions.c
new file mode 100644
index 000000000000..ffb8970fdc80
--- /dev/null
+++ b/lang/php53/files/patch-ext_standard_basic_functions.c
@@ -0,0 +1,10 @@
+--- ext/standard/basic_functions.c.orig Mon Jan 30 16:58:56 2006
++++ ext/standard/basic_functions.c Mon Jan 30 16:59:13 2006
+@@ -78,6 +78,7 @@
+ # include <sys/mman.h>
+ #endif
+
++#define HARTMUT_0
+ #ifdef HARTMUT_0
+ #include <getopt.h>
+ #endif