aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-10-11 05:31:30 +0800
committerlinimon <linimon@FreeBSD.org>2017-10-11 05:31:30 +0800
commitbc940feb08f69c198c2d6ba70142c26f6a35f8ff (patch)
treef3d89a0399e1e0896808a5ab7c804ecd549e47db /lang
parent8be4719cfd2cb75c5c21d067453d3464fc2be7e7 (diff)
downloadfreebsd-ports-gnome-bc940feb08f69c198c2d6ba70142c26f6a35f8ff.tar.gz
freebsd-ports-gnome-bc940feb08f69c198c2d6ba70142c26f6a35f8ff.tar.zst
freebsd-ports-gnome-bc940feb08f69c198c2d6ba70142c26f6a35f8ff.zip
For ports that are explicitly enabled on armv6, also enable them
on armv7. This has not been tested with an -exp run but should "do no harm". PR: 221894 (partial)
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime17/Makefile2
-rw-r--r--lang/erlang-runtime18/Makefile2
-rw-r--r--lang/erlang-runtime19/Makefile2
-rw-r--r--lang/erlang-runtime20/Makefile2
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/go/Makefile6
-rw-r--r--lang/go14/Makefile8
-rw-r--r--lang/luajit/Makefile2
-rw-r--r--lang/mono/Makefile2
-rw-r--r--lang/swi-pl/Makefile6
10 files changed, 17 insertions, 17 deletions
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 589ca8144fa4..f066634c619e 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -169,7 +169,7 @@ CONFIGURE_ARGS+=--enable-dirty-schedulers
MAKE_ARGS+= ARCH=x86
.endif
-.if ${ARCH} == armv6
+.if ${ARCH} == armv6 || ${ARCH} == armv7
MAKE_ARGS+= ARCH=arm
.endif
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index 2f3246110fc4..53e1b9ac4767 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -163,7 +163,7 @@ CONFIGURE_ARGS+=--enable-dirty-schedulers
MAKE_ARGS+= ARCH=x86
.endif
-.if ${ARCH} == armv6
+.if ${ARCH} == armv6 || ${ARCH} == armv7
MAKE_ARGS+= ARCH=arm
.endif
diff --git a/lang/erlang-runtime19/Makefile b/lang/erlang-runtime19/Makefile
index 610fcb9d7a4e..d3b800c7c96a 100644
--- a/lang/erlang-runtime19/Makefile
+++ b/lang/erlang-runtime19/Makefile
@@ -184,7 +184,7 @@ CONFIGURE_ARGS+=--enable-dirty-schedulers
MAKE_ARGS+= ARCH=x86
.endif
-.if ${ARCH} == armv6
+.if ${ARCH} == armv6 || ${ARCH} == armv7
MAKE_ARGS+= ARCH=arm
.endif
diff --git a/lang/erlang-runtime20/Makefile b/lang/erlang-runtime20/Makefile
index eeb801f7e5ab..3dd63daeaf4e 100644
--- a/lang/erlang-runtime20/Makefile
+++ b/lang/erlang-runtime20/Makefile
@@ -175,7 +175,7 @@ CONFIGURE_ARGS+=--enable-dirty-schedulers
MAKE_ARGS+= ARCH=x86
.endif
-.if ${ARCH} == armv6
+.if ${ARCH} == armv6 || ${ARCH} == armv7
MAKE_ARGS+= ARCH=arm
.endif
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 8867272a4da0..f93ad6dd5418 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -201,7 +201,7 @@ CONFIGURE_ARGS+=--enable-dirty-schedulers
MAKE_ARGS+= ARCH=x86
.endif
-.if ${ARCH} == armv6
+.if ${ARCH} == armv6 || ${ARCH} == armv7
MAKE_ARGS+= ARCH=arm
.endif
diff --git a/lang/go/Makefile b/lang/go/Makefile
index 7c9eea6e773b..ff236a1aa14f 100644
--- a/lang/go/Makefile
+++ b/lang/go/Makefile
@@ -31,18 +31,18 @@ sh_OLD_CMD= "/usr/bin/env bash"
sh_CMD= ${SH}
WRKSRC= ${WRKDIR}/go
-ONLY_FOR_ARCHS= i386 amd64 armv6
+ONLY_FOR_ARCHS= i386 amd64 armv6 armv7
OPTIONS_DEFINE= GO387
GO387_DESC= Do not generate code with SSE2 (for old x86 CPU)
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
GOARCH=386
.elif ${ARCH} == "amd64"
GOARCH=amd64
-.elif ${ARCH} == "armv6"
+.elif ${ARCH} == armv6 || ${ARCH} == armv7
GOARCH=arm
.else
IGNORE= unknown arch ${ARCH}
diff --git a/lang/go14/Makefile b/lang/go14/Makefile
index ed977a704d7b..efc500184a62 100644
--- a/lang/go14/Makefile
+++ b/lang/go14/Makefile
@@ -29,7 +29,7 @@ sh_CMD= ${SH}
WRKSRC= ${WRKDIR}/go
-ONLY_FOR_ARCHS= amd64 armv6 i386
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
.include <bsd.port.pre.mk>
@@ -38,13 +38,13 @@ ONLY_FOR_ARCHS= amd64 armv6 i386
CC=clang
.endif
-.if ${ARCH} == "i386"
+.if ${ARCH} == i386
GOARCH=386
GOOBJ=8
-.elif ${ARCH} == "amd64"
+.elif ${ARCH} == amd64
GOARCH=amd64
GOOBJ=6
-.elif ${ARCH} == "armv6"
+.elif ${ARCH} == armv6 || ${ARCH} == armv7
GOARCH=arm
GOOBJ=5
.else
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index fa3356aefc9f..0ecd589316cd 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -16,7 +16,7 @@ USE_LDCONFIG= yes
PLIST_SUB+= VERSION=${DISTVERSION}
-ONLY_FOR_ARCHS= amd64 armv6 i386
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386
ONLY_FOR_ARCHS_REASON= Requires newer gcc/clang to compile.
post-install:
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 320c3446020e..90876b4d937c 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -65,7 +65,7 @@ MAKE_ENV= MONO_SHARED_DIR="${WRKDIR}" \
TEST_TARGET= check
TEST_WRKSRC= ${WRKSRC}/mono/tests
-ONLY_FOR_ARCHS= amd64 armv6 i386 powerpc
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc
PORTSCOUT= limit:^\d+\.\d+\.[1-9]\d*
diff --git a/lang/swi-pl/Makefile b/lang/swi-pl/Makefile
index 710d72954467..fecb9a498a82 100644
--- a/lang/swi-pl/Makefile
+++ b/lang/swi-pl/Makefile
@@ -49,18 +49,18 @@ PLIST_SUB= DISTNAME=${SWIPLDIR} ARCH=${ARCH} OS=${OPSYS:tl} \
.include <bsd.port.pre.mk>
-.if (${ARCH} == "i386" || ${ARCH} == "powerpc" || ${ARCH} == "armv6")
+.if (${ARCH} == armv6 || ${ARCH} == armv7 || ${ARCH} == i386 || ${ARCH} == powerpc)
PLIST_SUB+= BITS=32
.else
PLIST_SUB+= BITS=64
.endif
-.if (${ARCH} == "amd64")
+.if (${ARCH} == amd64)
ARCH= x86_64
.endif
post-configure:
-.if ${ARCH} != "i386"
+.if ${ARCH} != i386
@${REINPLACE_CMD} -e '/^CMFLAGS=/s/$$/ -fPIC/' \
${WRKSRC}/packages/Dialect.defs
.endif