aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-02-23 03:50:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-02-23 03:50:54 +0800
commitc2a0292fc6d3f0437dca49e455144b5025961d9d (patch)
tree7d520303c9f6c5229a60f15a5ea8da803a01c170 /lang
parent1f5e37e809eaf6cbe40394723378aaa2be0ed578 (diff)
downloadfreebsd-ports-gnome-c2a0292fc6d3f0437dca49e455144b5025961d9d.tar.gz
freebsd-ports-gnome-c2a0292fc6d3f0437dca49e455144b5025961d9d.tar.zst
freebsd-ports-gnome-c2a0292fc6d3f0437dca49e455144b5025961d9d.zip
Fix build with OpenSSL 1.1.0 (security/openssl-devel)
This is a follow up commit of r461915. MFH: 2018Q1
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 1802c1053c1c..a97b9c6f3747 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -17,7 +17,9 @@ LICENSE= PSFL
USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
+CFLAGS+= -I${OPENSSLINC}
GNU_CONFIGURE= yes
+LIBS+= -L${OPENSSLLIB}
python_CMD= ${PREFIX}/bin/python${PYTHON_PORTVERSION:R}
SHEBANG_FILES= Lib/lib2to3/pgen2/*.py Lib/lib2to3/tests/*.py Lib/lib2to3/tests/data/*.py \
Lib/idlelib/*.py Lib/encodings/*.py Lib/test/*.py Lib/UserString.py \