aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-23 00:04:19 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-23 00:04:19 +0800
commitc7bd35dd7a04267304bb24e7763ce9a2f862c245 (patch)
treec5e899899564f09bbd94410678db0ab936c225e5 /lang
parent1570d70ff8e9cf8c52948fc11b4e6bf7fe881e65 (diff)
downloadfreebsd-ports-gnome-c7bd35dd7a04267304bb24e7763ce9a2f862c245.tar.gz
freebsd-ports-gnome-c7bd35dd7a04267304bb24e7763ce9a2f862c245.tar.zst
freebsd-ports-gnome-c7bd35dd7a04267304bb24e7763ce9a2f862c245.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket) Reported by: swills
Diffstat (limited to 'lang')
-rw-r--r--lang/cling/Makefile3
-rw-r--r--lang/gcc47/Makefile2
-rw-r--r--lang/gcc6/Makefile3
-rw-r--r--lang/hugs/Makefile5
-rw-r--r--lang/racket-minimal/Makefile7
-rw-r--r--lang/racket/Makefile6
6 files changed, 17 insertions, 9 deletions
diff --git a/lang/cling/Makefile b/lang/cling/Makefile
index bc615a2d7436..dea822ee573d 100644
--- a/lang/cling/Makefile
+++ b/lang/cling/Makefile
@@ -18,6 +18,9 @@ LICENSE_FILE_LLVM= ${WRKSRC}/LICENSE.TXT
LICENSE_FILE_NCSA= ${WRKSRC}/tools/cling/LICENSE.TXT
LICENSE_PERMS_LLVM= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+BROKEN_armv6= fails to compile: AArch64TargetMachine.cpp: relocation truncated to fit: R_ARM_CALL against symbol '__aeabi_uldivmod'
+BROKEN_powerpc64= fails to compile: IncrementalParser.cpp: 'to_string' is not a member of 'std'
+
WRKSRC= ${WRKDIR}/src
LLVM_RELEASE= 3.9.0
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 882b8f55bef5..4ebd356568ab 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
+BROKEN_powerpc64= fails to compile: libgcc2.c: In function '__powisf2': internal compiler error: Segmentation fault
+
.if defined(MAINTAINER_MODE)
BUILD_DEPENDS+= runtest:misc/dejagnu
.endif
diff --git a/lang/gcc6/Makefile b/lang/gcc6/Makefile
index 9c7d43788efb..fe02295604f9 100644
--- a/lang/gcc6/Makefile
+++ b/lang/gcc6/Makefile
@@ -20,6 +20,9 @@ LIB_DEPENDS= libgmp.so:math/gmp \
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
+BROKEN_powerpc64= fails to build: close.c: implicit declaration of function 'strdup'
+BROKEN_sparc64= fails to configure: cannot compute suffix of object files: cannot compile
+
.if defined(MAINTAINER_MODE)
BUILD_DEPENDS+= runtest:misc/dejagnu
.endif
diff --git a/lang/hugs/Makefile b/lang/hugs/Makefile
index 5a916ab1a292..b061ec98210c 100644
--- a/lang/hugs/Makefile
+++ b/lang/hugs/Makefile
@@ -13,6 +13,9 @@ COMMENT= Interpreter for the functional programming language Haskell 98
BUILD_DEPENDS= bash:shells/bash
+BROKEN_armv6= fails to compile: cppinput.c: invalid preprocessing directive \#!
+BROKEN_powerpc64= fails to compile: cppinput.c: detected recursion whilst expanding macro "vector"
+
WRKSRC= ${WRKDIR}/${DISTNAME}
HUGS_DATE= Sep2006
@@ -26,8 +29,6 @@ CONFIGURE_ARGS+= --with-pthreads
USE_GL= glut
USE_XORG= sm ice xmu xi x11
-BROKEN_ia64= dumps core during build
-
post-patch:
@${REINPLACE_CMD} 's/LIBS/LIBRARIES/' ${WRKSRC}/libraries/Makefile.in
@${REINPLACE_CMD} -e '/^install :: install_notes/d ; \
diff --git a/lang/racket-minimal/Makefile b/lang/racket-minimal/Makefile
index be6026f47212..4843e4652738 100644
--- a/lang/racket-minimal/Makefile
+++ b/lang/racket-minimal/Makefile
@@ -21,11 +21,10 @@ LICENSE= LGPL3
LIB_DEPENDS= libffi.so:devel/libffi
-BROKEN_armv6= does not build: error: GNU lightning does not support the current target
-BROKEN_aarch64= does not build: error: Unported platform
-BROKEN_powerpc64= does not build: jit.c: error: JIT_LOCAL4 undeclared
-BROKEN_sparc64= does not build
BROKEN_i386= does not build on i386 (Seg fault (internal error) at 0x606060a)
+BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in this function)
+NOT_FOR_ARCHS= armv6 aarch64 sparc64
+NOT_FOR_ARCHS_REASON= not yet ported to this arch
MAKE_JOBS_UNSAFE=yes
diff --git a/lang/racket/Makefile b/lang/racket/Makefile
index c41d3b5e08e3..39d98005ef86 100644
--- a/lang/racket/Makefile
+++ b/lang/racket/Makefile
@@ -22,12 +22,12 @@ LIB_DEPENDS= libffi.so:devel/libffi \
libcairo.so:graphics/cairo \
libpng.so:graphics/png
-BROKEN_armv6= does not build: error: GNU lightning does not support the current target
-BROKEN_aarch64= does not build: error: Unported platform
-BROKEN_sparc64= does not build
+BROKEN_powerpc64= fails to build: jit.c: 'JIT_LOCAL4' undeclared (first use in this function)
BROKEN_FreeBSD_10_i386= segfaults during build
BROKEN_FreeBSD_11_i386= segfaults during build
BROKEN_FreeBSD_12_i386= segfaults during build
+NOT_FOR_ARCHS= armv6 aarch64 sparc64
+NOT_FOR_ARCHS_REASON= not yet ported to this arch
MAKE_JOBS_UNSAFE=yes