aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2016-12-13 19:24:03 +0800
committergerald <gerald@FreeBSD.org>2016-12-13 19:24:03 +0800
commitc95bd5b800c3ab812b03c7fb5c2072e4e985945c (patch)
tree1b78e7e33e0a83cecc2b1fc2ab01ca39f3a4391c /lang
parent7cc99c67d20d3d630402dd3939a3081c23e96a22 (diff)
downloadfreebsd-ports-gnome-c95bd5b800c3ab812b03c7fb5c2072e4e985945c.tar.gz
freebsd-ports-gnome-c95bd5b800c3ab812b03c7fb5c2072e4e985945c.tar.zst
freebsd-ports-gnome-c95bd5b800c3ab812b03c7fb5c2072e4e985945c.zip
Update to the 20161211 development snapshot of GCC 7.
Remove files/patch-unwind-ia64.h since, like lang/gcc6 even, we no longer support ia64 (ONLY_FOR_ARCHS does not include ia64).
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc7-devel/Makefile2
-rw-r--r--lang/gcc7-devel/distinfo6
-rw-r--r--lang/gcc7-devel/files/patch-unwind-ia64.h21
3 files changed, 4 insertions, 25 deletions
diff --git a/lang/gcc7-devel/Makefile b/lang/gcc7-devel/Makefile
index ec8ffa4b4e2f..4280a6688c83 100644
--- a/lang/gcc7-devel/Makefile
+++ b/lang/gcc7-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 7.0.0.s20161204
+PORTVERSION= 7.0.0.s20161211
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc7-devel/distinfo b/lang/gcc7-devel/distinfo
index fa259730cd10..e68afa1bc04e 100644
--- a/lang/gcc7-devel/distinfo
+++ b/lang/gcc7-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480892913
-SHA256 (gcc-7-20161204.tar.bz2) = ff39758b70e33db3ecd79fb4ba4d49b98b565a6868619bf300abbbaf2ad89cc0
-SIZE (gcc-7-20161204.tar.bz2) = 78701779
+TIMESTAMP = 1481542578
+SHA256 (gcc-7-20161211.tar.bz2) = c198400bf2e7f3ebad3b37c81a034d6b7e2a1f172d983072e58a95566ace9984
+SIZE (gcc-7-20161211.tar.bz2) = 78763334
diff --git a/lang/gcc7-devel/files/patch-unwind-ia64.h b/lang/gcc7-devel/files/patch-unwind-ia64.h
deleted file mode 100644
index 82e103a543c5..000000000000
--- a/lang/gcc7-devel/files/patch-unwind-ia64.h
+++ /dev/null
@@ -1,21 +0,0 @@
-2012-12-17 Gerald Pfeifer <gerald@pfeifer.com>
- Anton Shterenlikht <mexas@bristol.ac.uk>
-
- PR target/45650
- * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
- hidden on FreeBSD.
-
---- UTC
-Index: libgcc/config/ia64/unwind-ia64.h
-===================================================================
---- libgcc/config/ia64/unwind-ia64.h
-+++ libgcc/config/ia64/unwind-ia64.h (working copy)
-@@ -49,4 +49,7 @@
- extern struct unw_table_entry *
- _Unwind_FindTableEntry (void *pc, unw_word *segment_base,
- unw_word *gp, struct unw_table_entry *ent)
-- __attribute__ ((__visibility__ ("hidden")));
-+#ifndef __FreeBSD__
-+ __attribute__ ((__visibility__ ("hidden")))
-+#endif
-+ ;