aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-01-31 21:04:13 +0800
committerobraun <obraun@FreeBSD.org>2003-01-31 21:04:13 +0800
commitccb10ea115249d29c6500d90e6a30ef4c61ef9c6 (patch)
tree69aa5c19f420e069f34186f302d06a8e98b7f8dd /lang
parent557ee40db8024477f91306bc44722d7b6e679b55 (diff)
downloadfreebsd-ports-gnome-ccb10ea115249d29c6500d90e6a30ef4c61ef9c6.tar.gz
freebsd-ports-gnome-ccb10ea115249d29c6500d90e6a30ef4c61ef9c6.tar.zst
freebsd-ports-gnome-ccb10ea115249d29c6500d90e6a30ef4c61ef9c6.zip
Fix libs.
PR: ports/47486 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/onyx/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 28c6010f7755..be55f39349bf 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= onyx
PORTVERSION= 4.2.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.canonware.com/download/onyx/
@@ -16,15 +17,21 @@ BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
LIB_DEPENDS= edit.5:${PORTSDIR}/devel/libedit \
pcre.0:${PORTSDIR}/devel/pcre
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE} \
+ --with-pcre-prefix=${LOCALBASE} \
+ --disable-slate
INSTALLS_SHLIB= yes
MAN1= onyx.1 onyx_config.1
PLIST_SUB= ONYX_VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+
do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook)