aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-09-05 00:02:16 +0800
committermat <mat@FreeBSD.org>2015-09-05 00:02:16 +0800
commitd4128f24283cd93f0120d4a58ec7114798bf4877 (patch)
tree2d206dd00b752621c542c0b063bec6c9471a3355 /lang
parent8b9dfbc45e47a8dc3875beb7d9bacb1046409221 (diff)
downloadfreebsd-ports-gnome-d4128f24283cd93f0120d4a58ec7114798bf4877.tar.gz
freebsd-ports-gnome-d4128f24283cd93f0120d4a58ec7114798bf4877.tar.zst
freebsd-ports-gnome-d4128f24283cd93f0120d4a58ec7114798bf4877.zip
Convert most ports using cloud.github.com to GHC.
Convert a couple to github, and use some options helpers on the way. Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/rhino/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index a025ff2ce968..73922d5c2d31 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -4,10 +4,10 @@
PORTNAME= rhino
DISTVERSION= 1_7R4
CATEGORIES= lang java
-MASTER_SITES= http://cloud.github.com/downloads/mozilla/rhino/:rhino \
+MASTER_SITES= GHC \
LOCAL/nivit/${PORTNAME}/:swingex \
APACHE/xmlbeans/binaries/:xmlbeans
-DISTFILES= ${PORTNAME}${DISTVERSION}.zip:rhino \
+DISTFILES= ${PORTNAME}${DISTVERSION}.zip \
src.zip:swingex \
xmlbeans-2.5.0.zip:xmlbeans
DIST_SUBDIR= ${PORTNAME}
@@ -35,6 +35,8 @@ OPTIONS_DEFAULT= LINEDIT
OPTIONS_DEFINE= LINEDIT
USES= zip
+USE_GITHUB= yes
+GH_ACCOUNT= mozilla
.include <bsd.port.options.mk>