aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-08-08 10:04:56 +0800
committermezz <mezz@FreeBSD.org>2012-08-08 10:04:56 +0800
commitd4ade5b95decb3f6c31252139b4557b30191218f (patch)
tree2ed673e272c775d26bad97b23a62f980e30418df /lang
parentb5b2a864917bd8637f9d94a9b505cf8dc781c1e1 (diff)
downloadfreebsd-ports-gnome-d4ade5b95decb3f6c31252139b4557b30191218f.tar.gz
freebsd-ports-gnome-d4ade5b95decb3f6c31252139b4557b30191218f.tar.zst
freebsd-ports-gnome-d4ade5b95decb3f6c31252139b4557b30191218f.zip
- The tarball has been rerolled. The diff doesn't find any of change, so
there was no change. - Fix the build on FreeBSD 7.x. - Improvement on patch-lib_stdlib_extract-import-plugin.sh, functions better and only affect on build side (not runtime). Reported by: pointyhat (beat)
Diffstat (limited to 'lang')
-rw-r--r--lang/opa/distinfo4
-rw-r--r--lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh2
-rw-r--r--lang/opa/files/patch-tools_build_myocamlbuild_prefix.ml11
3 files changed, 14 insertions, 3 deletions
diff --git a/lang/opa/distinfo b/lang/opa/distinfo
index e895da283536..45fc4bf63db1 100644
--- a/lang/opa/distinfo
+++ b/lang/opa/distinfo
@@ -1,2 +1,2 @@
-SHA256 (opa_v2988.tar.gz) = fb3257d943465f5901dade3fd1a18a5dbdacb2e27a892a76fba57e770ce3ea9f
-SIZE (opa_v2988.tar.gz) = 10006465
+SHA256 (opa_v2988.tar.gz) = 13b0a95843239ca81bab3cacc3361a11ca92a63801c9f67c0ef1f08f7c349771
+SIZE (opa_v2988.tar.gz) = 10006468
diff --git a/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh b/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh
index 2b653916098b..6de2addb1d42 100644
--- a/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh
+++ b/lang/opa/files/patch-lib_stdlib_extract-import-plugin.sh
@@ -5,4 +5,4 @@
. ${OPA_SOURCE_DIR:-$(dirname $0)/../../}/tools/platform_helper.sh
-sed -n "s%^ *import-plugin *\\(.*\\) *$%\\1%p" $1 | sed -e "s/{//" -e "s/}//" -e "s/, */\n/g"
-+sed -n "s%^ *import-plugin *\\(.*\\) *$%\\1%p" $1 | sed -e "s/{//" -e "s/}//" | tr ', ' '\n'
++sed -n "s%^ *import-plugin *\\(.*\\) *$%\\1%p" $1 | sed -e "s/{//" -e "s/}//" -e "s/, /,/g" | tr ',' '\n'
diff --git a/lang/opa/files/patch-tools_build_myocamlbuild_prefix.ml b/lang/opa/files/patch-tools_build_myocamlbuild_prefix.ml
new file mode 100644
index 000000000000..e3954aec5aed
--- /dev/null
+++ b/lang/opa/files/patch-tools_build_myocamlbuild_prefix.ml
@@ -0,0 +1,11 @@
+--- tools/build/myocamlbuild_prefix.ml.orig 2012-08-07 20:41:25.000000000 -0500
++++ tools/build/myocamlbuild_prefix.ml 2012-08-07 20:41:44.000000000 -0500
+@@ -342,7 +342,7 @@
+ for increased compatibility with GNU sed. Since FreeBSD still
+ supports 7.x that does not has -r, so use -E instead. The -r
+ does not exist in MacOS X sed either. *)
+- if is_fbsd && is_mac then
++ if is_fbsd || is_mac then
+ Cmd(S[sed; A"-E"; A sedexpr; P(env "%.mllibp"); Sh">"; P(env "%.mllib")])
+ else
+ Cmd(S[sed; A"-r"; A sedexpr; P(env "%.mllibp"); Sh">"; P(env "%.mllib")]));