aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-01-09 05:31:22 +0800
committeredwin <edwin@FreeBSD.org>2006-01-09 05:31:22 +0800
commitdb9b120d0c4a0795e54f843b0927725dfaff053a (patch)
tree3c4c27b8b12e5f216219c5689acb99cc5c4f288d /lang
parent73f5aca6efbcb74092bbccea498bd471bb58e994 (diff)
downloadfreebsd-ports-gnome-db9b120d0c4a0795e54f843b0927725dfaff053a.tar.gz
freebsd-ports-gnome-db9b120d0c4a0795e54f843b0927725dfaff053a.tar.zst
freebsd-ports-gnome-db9b120d0c4a0795e54f843b0927725dfaff053a.zip
Spidermonkey version update to 1.5 with fixes for ia64/amd64
Update source to spidermonkey 1.5 and patched (much thanks to Anish Mistry) to fix compilation problems under amd64 (and presumably ia64 too but untested) and to make the build thread-safe. PR: ports/91522 Submitted by: Dan Rench <citric@cubicone.tmetic.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/spidermonkey/Makefile13
-rw-r--r--lang/spidermonkey/distinfo13
-rw-r--r--lang/spidermonkey/files/patch-config17
-rw-r--r--lang/spidermonkey/files/patch-warnings24
4 files changed, 29 insertions, 38 deletions
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index 2d395f3c780e..235cace7433f 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= spidermonkey
-DISTVERSION= 1.5-rc6a
-PORTREVISION= 1
+DISTVERSION= 1.5
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= js
@@ -16,7 +15,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= citric@cubicone.tmetic.com
COMMENT= A standalone JavaScript interpreter from the Mozilla project
-CONFLICTS= njs-*
+CONFLICTS= njs-[0-9]*
.if !defined(WITHOUT_TEST)
USE_PERL5_BUILD=test harness
@@ -25,7 +24,13 @@ PATCHFILES= spidermonkey-patch-tests-ecma.bz2 \
spidermonkey-patch-tests-js.bz2
PATCH_SITES= http://virtual-estates.net/~mi/port-stuff/
BUILD_DEPENDS+= ${SITE_PERL}/Getopt/Mixed.pm:${PORTSDIR}/devel/p5-Getopt-Mixed
-DISTFILES+= js-tests-20021118${EXTRACT_SUFX}
+LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr
+MAKE_ARGS+= JS_THREADSAFE=YES \
+ PROG_LIBS="-lreadline -ltermcap -lm ${PTHREAD_LIBS}" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include/nspr
+
+DISTFILES+= older-packages/js-tests-20021118${EXTRACT_SUFX}
post-build: test
post-patch:
#
diff --git a/lang/spidermonkey/distinfo b/lang/spidermonkey/distinfo
index 69545ec8d678..0f1140f9be77 100644
--- a/lang/spidermonkey/distinfo
+++ b/lang/spidermonkey/distinfo
@@ -1,10 +1,15 @@
-MD5 (js-1.5-rc6a.tar.gz) = 25e1d1dd2674d85883391b6b42a7b02f
-SIZE (js-1.5-rc6a.tar.gz) = 1058911
-MD5 (js-tests-20021118.tar.gz) = df89464084e583a075a782ad66da5370
-SIZE (js-tests-20021118.tar.gz) = 803198
+MD5 (js-1.5.tar.gz) = 863bb6462f4ce535399a7c6276ae6776
+SHA256 (js-1.5.tar.gz) = ef72a154320c9949f8de0732e8dbfa186b83feb0a5e890d90807757de9998585
+SIZE (js-1.5.tar.gz) = 958135
+MD5 (older-packages/js-tests-20021118.tar.gz) = df89464084e583a075a782ad66da5370
+SHA256 (older-packages/js-tests-20021118.tar.gz) = 75878c90ed8641aaddcf4cb0b277353c6e7be31e6539beffa44f33bdfe69181f
+SIZE (older-packages/js-tests-20021118.tar.gz) = 803198
MD5 (spidermonkey-patch-tests-ecma.bz2) = 73ec1e37821deff69e68eac2192a2cd2
+SHA256 (spidermonkey-patch-tests-ecma.bz2) = 9f6ef721145e12bfca1a8ecdd0e8692fc916fef792927d9503bd40bb86f15f21
SIZE (spidermonkey-patch-tests-ecma.bz2) = 5702
MD5 (spidermonkey-patch-tests-timezone.bz2) = 9b392c970d878f3defcd7e3e7ddeb0b5
+SHA256 (spidermonkey-patch-tests-timezone.bz2) = 94322a6541303ac66ffad5cdfdc4af8d5ec14ce74c2dc4709736941abd4bd8bf
SIZE (spidermonkey-patch-tests-timezone.bz2) = 7658
MD5 (spidermonkey-patch-tests-js.bz2) = 20770d4e82fff61c1bbb5ff91d2551ec
+SHA256 (spidermonkey-patch-tests-js.bz2) = f930c31005778eeb40f4d3fa10a6d65ab2991c95c990c60712f9d2696c041088
SIZE (spidermonkey-patch-tests-js.bz2) = 3685
diff --git a/lang/spidermonkey/files/patch-config b/lang/spidermonkey/files/patch-config
index 0b3e7fc887ac..a1f5484eeba6 100644
--- a/lang/spidermonkey/files/patch-config
+++ b/lang/spidermonkey/files/patch-config
@@ -27,9 +27,10 @@
+ $(CC) -o $@ $(CFLAGS) $(PROG_OBJS) -L$(OBJDIR) -ljs $(LDFLAGS) $(OTHER_LIBS) \
$(PROG_LIBS)
endif
---- config/Linux_All.mk Thu May 15 20:21:08 2003
-+++ config/Linux_All.mk Wed Aug 10 23:46:05 2005
-@@ -37,7 +37,7 @@
+--- config/Linux_All.mk.orig Tue May 10 15:53:44 2005
++++ config/Linux_All.mk Sat Dec 10 21:17:45 2005
+@@ -41,9 +41,9 @@
+ # Config for all versions of Linux
#
-CC = gcc
@@ -40,14 +41,18 @@
+CFLAGS += -Wall -Werror # XXX do these work with non-gcc and non-icc?
OS_CFLAGS = -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R
-@@ -70,5 +70,5 @@
+ RANLIB = echo
+@@ -74,7 +74,7 @@
+
GFX_ARCH = x
-OS_LIBS = -lm -lc
+OS_LIBS = -lm
ASFLAGS += -x assembler-with-cpp
-@@ -84,15 +84,11 @@
+
+@@ -88,16 +88,12 @@
+ endif
# Use the editline library to provide line-editing support.
-JS_EDITLINE = 1
@@ -56,7 +61,7 @@
-ifeq ($(CPU_ARCH),x86_64)
-# Use VA_COPY() standard macro on x86-64
-# FIXME: better use it everywhere
- OS_CFLAGS += -DHAVE_VA_COPY
+ OS_CFLAGS += -DHAVE_VA_COPY -DVA_COPY=va_copy
-endif
-ifeq ($(CPU_ARCH),x86_64)
diff --git a/lang/spidermonkey/files/patch-warnings b/lang/spidermonkey/files/patch-warnings
index 70d717cae5d4..f7877652ac02 100644
--- a/lang/spidermonkey/files/patch-warnings
+++ b/lang/spidermonkey/files/patch-warnings
@@ -227,13 +227,6 @@
+ sharpid = (jsatomid)(uintptr_t)he->value;
if (sharpid == 0) {
*sp = NULL;
-@@ -1104,5 +1104,5 @@
- const JSResolvingKey *key = (const JSResolvingKey *)ptr;
-
-- return ((JSDHashNumber)key->obj >> JSVAL_TAGBITS) ^ key->id;
-+ return ((JSDHashNumber)(uintptr_t)key->obj >> JSVAL_TAGBITS) ^ key->id;
- }
-
--- jsopcode.c Thu Jun 10 00:33:52 2004
+++ jsopcode.c Sat Aug 6 19:13:50 2005
@@ -181,5 +181,5 @@
@@ -254,23 +247,6 @@
+ fprintf(fp, "\n\t%d: %td", i, off);
pc2 += jmplen;
}
-@@ -230,5 +230,5 @@
- {
- jsbytecode *pc2;
-- jsint npairs;
-+ int npairs;
-
- jmplen = (type == JOF_LOOKUPSWITCH) ? JUMP_OFFSET_LEN
-@@ -237,7 +237,7 @@
- off = GetJumpOffset(pc, pc2);
- pc2 += jmplen;
-- npairs = (jsint) GET_ATOM_INDEX(pc2);
-+ npairs = GET_ATOM_INDEX(pc2);
- pc2 += ATOM_INDEX_LEN;
-- fprintf(fp, " offset %d npairs %u", off, (uintN) npairs);
-+ fprintf(fp, " offset %td npairs %d", off, npairs);
- while (npairs) {
- atom = GET_ATOM(cx, script, pc2);
@@ -253,5 +253,5 @@
if (!cstr)
return 0;