aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-01-13 18:39:22 +0800
committernetchild <netchild@FreeBSD.org>2003-01-13 18:39:22 +0800
commitdfbcd0dcda065acfa9c87218f51e7305e77d7fcd (patch)
treeb39822565df9d899da468ab1a396a5d0cf69e279 /lang
parent092554d992464d0a77d35f798badb04feb9bccc5 (diff)
downloadfreebsd-ports-gnome-dfbcd0dcda065acfa9c87218f51e7305e77d7fcd.tar.gz
freebsd-ports-gnome-dfbcd0dcda065acfa9c87218f51e7305e77d7fcd.tar.zst
freebsd-ports-gnome-dfbcd0dcda065acfa9c87218f51e7305e77d7fcd.zip
Remove the "warning -> error" options for excessive function arguments,
they seem to cause problems in some cases. Noticed by: roberto, marius@alchemy.franken.de
Diffstat (limited to 'lang')
-rw-r--r--lang/icc/Makefile3
-rw-r--r--lang/icc7/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 698fa26bd144..7d3d6a6d6722 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 7.0.078
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pu_${PORTVERSION}
@@ -102,7 +103,7 @@ post-patch:
.for i in icc.cfg icpc.cfg
@${REINPLACE_CMD} -i "" -e 's:-Xlinker -rpath -Xlinker <INSTALLDIR>/${COMPILERDIR}/ia32/lib::g' \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
- @${ECHO} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n\n-Qwr1125\n-Qwe140\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+ @${ECHO} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.if ${OSVERSION} >= 500039
@${ECHO} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endif
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 698fa26bd144..7d3d6a6d6722 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 7.0.078
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_pu_${PORTVERSION}
@@ -102,7 +103,7 @@ post-patch:
.for i in icc.cfg icpc.cfg
@${REINPLACE_CMD} -i "" -e 's:-Xlinker -rpath -Xlinker <INSTALLDIR>/${COMPILERDIR}/ia32/lib::g' \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
- @${ECHO} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n\n-Qwr1125\n-Qwe140\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
+ @${ECHO} -e "-Qlocation,ld,${PREFIX}/intel/${COMPILERDIR}/ia32/bin/ldwrapper\n\n-Ulinux\n-U__linux__\n-U__linux\n\n-D__FreeBSD__=${ICCCFGVAL}\n-D__ELF__=1\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.if ${OSVERSION} >= 500039
@${ECHO} -e "-D__wchar_t=__ct_rune_t\n" >>${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/${i}
.endif