aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-05-28 21:52:33 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2020-05-28 21:52:33 +0800
commite7d17eb8674b0b6fab8a3ef5684cd92c8c306bab (patch)
treed94abc3a8df325a515ab6f1dbffc53c85efb6a47 /lang
parentf2191cb27cebc4d310b3126119bb3112be91da0c (diff)
downloadfreebsd-ports-gnome-e7d17eb8674b0b6fab8a3ef5684cd92c8c306bab.tar.gz
freebsd-ports-gnome-e7d17eb8674b0b6fab8a3ef5684cd92c8c306bab.tar.zst
freebsd-ports-gnome-e7d17eb8674b0b6fab8a3ef5684cd92c8c306bab.zip
Recompile _sysconfigdata.py after reinplacing it
PR: 246618 With hat: portmgr
Diffstat (limited to 'lang')
-rw-r--r--lang/python37/Makefile6
-rw-r--r--lang/python38/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 14ce6165f6bc..adcf9b8d9277 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -125,6 +125,12 @@ post-install:
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
.endif
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index bf3a72f27576..be8d1548aa24 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -132,6 +132,12 @@ post-install:
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
.endif