aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-28 06:16:50 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-28 06:16:50 +0800
commite86ddfcd7a9b7f4cf8deaa6a2e82d1a8d7fd3f23 (patch)
tree1b2df8c09e0cb56901d85fbbb3eef88a094ae8c6 /lang
parent5b4b6a0fe9b23bf8c3baba1473cd9772df348a55 (diff)
downloadfreebsd-ports-gnome-e86ddfcd7a9b7f4cf8deaa6a2e82d1a8d7fd3f23.tar.gz
freebsd-ports-gnome-e86ddfcd7a9b7f4cf8deaa6a2e82d1a8d7fd3f23.tar.zst
freebsd-ports-gnome-e86ddfcd7a9b7f4cf8deaa6a2e82d1a8d7fd3f23.zip
Mark some ports failing on armv6, for errors classified as "linker_error".
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/mosh/Makefile3
-rw-r--r--lang/nim/Makefile9
-rw-r--r--lang/siod/Makefile3
-rw-r--r--lang/spidermonkey17/Makefile4
4 files changed, 14 insertions, 5 deletions
diff --git a/lang/mosh/Makefile b/lang/mosh/Makefile
index 914f31d2ad7a..36e0d41a60d1 100644
--- a/lang/mosh/Makefile
+++ b/lang/mosh/Makefile
@@ -16,6 +16,9 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libgmp.so:math/gmp \
libonig.so:devel/oniguruma5
+BROKEN_armv6= fails to link: os_dep.c: undefined reference to '__stack_base__'
+BROKEN_mips64= fails to compile: os_dep.c: redefinition of 'GC_register_dynamic_libraries'
+
CONFLICTS_INSTALL= mosh-1.[0-9].*
USES= gmake ssl
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 8b03ed939ea1..ce14e01b623c 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -11,10 +11,11 @@ COMMENT= Nim programming language
LICENSE= MIT
-BROKEN_aarch64= Does not compile: crt1.c: undefined reference to main
-BROKEN_mips64= Does not build: build.sh: clang: not found
-BROKEN_powerpc64= Does not build: build.sh: clang: not found
-BROKEN_sparc64= Does not build: build.sh: clang: not found
+BROKEN_aarch64= fails to compile: crt1.c: undefined reference to main
+BROKEN_armv6= fails to compile: crt1.c: undefined reference to main
+BROKEN_mips64= fails to build: build.sh: clang: not found
+BROKEN_powerpc64= fails to build: build.sh: clang: not found
+BROKEN_sparc64= fails to build: build.sh: clang: not found
TOOLS_DESC= Build and install nimgrep and nimsuggest
diff --git a/lang/siod/Makefile b/lang/siod/Makefile
index 33befa1fe403..3c32836b9fdb 100644
--- a/lang/siod/Makefile
+++ b/lang/siod/Makefile
@@ -11,6 +11,9 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Small footprint implementation of the Scheme programming language
+BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
+
USE_LDCONFIG= yes
NO_WRKSUBDIR= yes
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index 86f9da59c164..7257b1ac170e 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -20,7 +20,9 @@ MAKE_ARGS+= JS_THREADSAFE=YES \
LDFLAGS="-L${LOCALBASE}/lib"
CFLAGS+= -I${LOCALBASE}/include/nspr
-BROKEN_sparc64= Does not build on sparc64: fails to link
+BROKEN_armv6= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_mips64= fails to link: final link failed: Nonrepresentable section on output
+BROKEN_sparc64= fails to link
USES= gmake ncurses readline
MAKEFILE= Makefile.ref