aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2003-04-02 06:49:30 +0800
committergerald <gerald@FreeBSD.org>2003-04-02 06:49:30 +0800
commitec811e873572667403fbfd4af275c51f7dbe6689 (patch)
tree23f71a2014bd3f46bdba95d90394aa7271cf4f07 /lang
parentb9a6c23e4eeb920e790c585dc31bf710c5a08f60 (diff)
downloadfreebsd-ports-gnome-ec811e873572667403fbfd4af275c51f7dbe6689.tar.gz
freebsd-ports-gnome-ec811e873572667403fbfd4af275c51f7dbe6689.tar.zst
freebsd-ports-gnome-ec811e873572667403fbfd4af275c51f7dbe6689.zip
Simplify the shell code used by the pre-patch target.
Suggested by: obrien Reviewed by: Dan Nelson <dnelson@allantgroup.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc32/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index b509ba996ddb..fdb28159ab39 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -127,11 +127,10 @@ do-extract:
.if defined(WITH_BOUNDSCHECKING)
# Extract bounds-checking patch, removing the ada parts of the patch with sed.
pre-patch:
- ( cd ${_DISTDIR} && \
- ${BZCAT} ${BCPATCH} | \
- ${SED} -e '/^--- .*ada/,/^diff/d' | \
- ${PATCH} -d ${PATCH_WRKSRC} -E -p1 --quiet \
- )
+ cd ${_DISTDIR} ; \
+ ${BZCAT} ${BCPATCH} | \
+ ${SED} -e '/^--- .*ada/,/^diff/d' | \
+ ${PATCH} -d ${PATCH_WRKSRC} -E -p1 --quiet
.endif
pre-configure: