aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2014-11-04 17:14:21 +0800
committerdemon <demon@FreeBSD.org>2014-11-04 17:14:21 +0800
commitf0aafdf76211800422ec9948a2d2afdcfac32f2d (patch)
tree0555c114031e18e9bc04687858ab96a799454247 /lang
parent03ef3ba8a262dd304b80d8f4337109b146d36877 (diff)
downloadfreebsd-ports-gnome-f0aafdf76211800422ec9948a2d2afdcfac32f2d.tar.gz
freebsd-ports-gnome-f0aafdf76211800422ec9948a2d2afdcfac32f2d.tar.zst
freebsd-ports-gnome-f0aafdf76211800422ec9948a2d2afdcfac32f2d.zip
Add an option to use libffi from ports instead of bundled version.
Submitted by: cy Reviewed by: koobs
Diffstat (limited to 'lang')
-rw-r--r--lang/python27/Makefile12
-rw-r--r--lang/python32/Makefile12
-rw-r--r--lang/python33/Makefile12
3 files changed, 27 insertions, 9 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index f6d54bc96ad3..4c3cd7ca6c5e 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python27
PORTVERSION= 2.7.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -34,8 +34,8 @@ PLIST_SUB= ABI=${ABIFLAGS} \
PORTVERSION=${PORTVERSION} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC SEM THREADS
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC SEM THREADS UCS4
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC SEM THREADS LIBFFI
+OPTIONS_DEFAULT= IPV6 NLS PYMALLOC SEM THREADS UCS4 LIBFFI
OPTIONS_SINGLE= UNICODE
OPTIONS_SINGLE_UNICODE= UCS2 UCS4
@@ -45,6 +45,7 @@ NLS_DESC= Enable gettext support for the locale module
UCS2_DESC= Enable UCS2 Unicode Strings
UCS4_DESC= Enable UCS4 Unicode Strings
PYMALLOC_DESC= Enable specialized mallocs
+LIBFFI_DESC= Use libffi from ports instead of bundled version
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
@@ -88,6 +89,11 @@ MAKE_ENV+= UNAME_m="powerpc64"
CFLAGS+= -DPYTHON_DEFAULT_RECURSION_LIMIT=900
.endif
+.if ${PORT_OPTIONS:MLIBFFI}
+CONFIGURE_ARGS+= --with-system-ffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
+.endif
+
# See http://bugs.freebsd.org/115940
.if !exists(/usr/bin/ypcat) || defined(WITHOUT_NIS) # the world with NO_NIS
PLIST_SUB+= NO_NIS="@comment "
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index d6f21c1889be..9ba8a8e45f6f 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python32
PORTVERSION= 3.2.5
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -33,13 +33,14 @@ MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC UCS4
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS UCS4
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC UCS4 LIBFFI
+OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS UCS4 LIBFFI
OPTIONS_SUB= yes
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
TSC_DESC= Enable processor timestamp counter profiling
+LIBFFI_DESC= Use libffi from ports instead of bundled version
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
@@ -75,6 +76,11 @@ CONFIGURE_ARGS+= --without-pymalloc
ABIFLAGS:= d${ABIFLAGS}
.endif
+.if ${PORT_OPTIONS:MLIBFFI}
+CONFIGURE_ARGS+= --with-system-ffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
+.endif
+
.if !empty(ABIFLAGS)
PLIST_FILES+= bin/python3.2%%ABI%%
PLIST_FILES+= bin/python3.2%%ABI%%-config
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index c7872f59ff29..61706e10b759 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -2,7 +2,7 @@
PORTNAME= python33
PORTVERSION= 3.3.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ftp/python/${PORTVERSION}
@@ -33,13 +33,14 @@ MAKE_ARGS+= LIBPC="${PREFIX}/libdata/pkgconfig" # Until pathfix gets support
PLIST_SUB= ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC
-OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS
+OPTIONS_DEFINE= DEBUG IPV6 NLS PYMALLOC THREADS TSC LIBFFI
+OPTIONS_DEFAULT= IPV6 NLS PYMALLOC THREADS LIBFFI
OPTIONS_SUB= yes
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
TSC_DESC= Enable processor timestamp counter profiling
+LIBFFI_DESC= Use libffi from ports instead of bundled version
DEBUG_CONFIGURE_WITH= pydebug
IPV6_CONFIGURE_ENABLE= ipv6
@@ -69,6 +70,11 @@ ABIFLAGS:= m${ABIFLAGS}
ABIFLAGS:= d${ABIFLAGS}
.endif
+.if ${PORT_OPTIONS:MLIBFFI}
+CONFIGURE_ARGS+= --with-system-ffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
+.endif
+
.if !empty(ABIFLAGS)
PLIST_FILES+= bin/python3.3%%ABI%%
PLIST_FILES+= bin/python3.3%%ABI%%-config