aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-04-13 14:05:49 +0800
committerdinoex <dinoex@FreeBSD.org>2003-04-13 14:05:49 +0800
commitf1748499917854fbbb028ced057ae601bc4e8be8 (patch)
tree08ef8650a8cb1f461f481ff9dc051e0d0f9c1133 /lang
parent3e0d59d4f3838eded47e81d1f3bd0d065137ae08 (diff)
downloadfreebsd-ports-gnome-f1748499917854fbbb028ced057ae601bc4e8be8.tar.gz
freebsd-ports-gnome-f1748499917854fbbb028ced057ae601bc4e8be8.tar.zst
freebsd-ports-gnome-f1748499917854fbbb028ced057ae601bc4e8be8.zip
1) COMMENT can be overrritten by a slave port (suggested by obrien)
2) Option WANT_SHAREDLIBS now uses ldconfig, so LIB_DEPENDS work. fix PLIST so critical file libgcc_s.so.1 is included. no response from obrien since 2003-03-31 Approved by: gerald
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc32/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index edfa4bb7bbef..ccf862df660d 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -24,7 +24,7 @@ DISTFILES= gcc-core-${PORTVERSION}${EXTRACT_SUFX} \
gcc-objc-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= gerald@FreeBSD.org
-COMMENT= GNU Compiler Collection 3.2.2
+COMMENT?= GNU Compiler Collection 3.2.2
.if defined (WITH_BOUNDSCHECKING)
# Fetch another file, but don't extract it. Also add another patchfile.
@@ -68,6 +68,9 @@ CONFIGURE_ARGS+= --with-system-zlib --includedir=${TARGLIB}/include/Java
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
.if defined(WANT_SHAREDLIBS)
CONFIGURE_ARGS+= --enable-shared
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
+EXTRA_SHLIB= libgcc_s
.else
CONFIGURE_ARGS+= --disable-shared
.endif
@@ -173,7 +176,7 @@ post-install:
${MV} -f ${PREFIX}/bin/gccbug ${PREFIX}/bin/gccbug-${PORTVERSION}
# These 3 libraries are moved from PREFIX/lib to avoid conflicts
# with the stock compiler.
-.for file in libstdc++ libsupc++ libg2c libfrtbegin libobjc
+.for file in libstdc++ libsupc++ libg2c libfrtbegin libobjc ${EXTRA_SHLIB}
${MV} -f ${PREFIX}/lib/${file}.* ${TARGLIB}
.endfor
-${MV} -f ${PREFIX}/lib/ieee ${TARGLIB}