aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-08-20 13:57:34 +0800
committerriggs <riggs@FreeBSD.org>2016-08-20 13:57:34 +0800
commitfa9bc4c67903467b15313c86547b3e510373e0cd (patch)
tree21bbe869da1ae0046c7d7953486f63928091d2a9 /lang
parent5db8d581790a97a89c20428519a7d8d66c3f81d4 (diff)
downloadfreebsd-ports-gnome-fa9bc4c67903467b15313c86547b3e510373e0cd.tar.gz
freebsd-ports-gnome-fa9bc4c67903467b15313c86547b3e510373e0cd.tar.zst
freebsd-ports-gnome-fa9bc4c67903467b15313c86547b3e510373e0cd.zip
Update to upstream release 1.11.0
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile6
-rw-r--r--lang/rust/distinfo.amd6410
-rw-r--r--lang/rust/distinfo.i38610
-rw-r--r--lang/rust/files/patch-configure8
-rw-r--r--lang/rust/files/patch-mk_rt.mk12
-rw-r--r--lang/rust/files/patch-src_compiler-rt_cmake_config-ix.cmake26
-rw-r--r--lang/rust/files/patch-src_etc_get-stage0.py14
-rw-r--r--lang/rust/pkg-plist4
8 files changed, 74 insertions, 16 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 311603856b1c..1c8043bf5f2c 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rust
-PORTVERSION?= 1.10.0
+PORTVERSION?= 1.11.0
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/dist/:bootstrap \
@@ -22,6 +22,8 @@ LICENSE_COMB= dual
# APACHE20 license is standard, see Templates/Licenses/APACHE20
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE-MIT
+BUILD_DEPENDS= cmake:devel/cmake
+
ONLY_FOR_ARCHS?= amd64 i386
ONLY_FOR_ARCHS_REASON= requires prebuilt bootstrap compiler
@@ -36,7 +38,7 @@ CONFLICTS_BUILD?= rust-nightly
CONFLICTS_BUILD+= ${PKGBASE}
CONFLICTS_INSTALL?= rust-nightly
-RUST_BOOT_VERSION?= 1.9.0
+RUST_BOOT_VERSION?= 1.10.0
RUST_BOOT= rustc-${RUST_BOOT_VERSION}-${RUST_TARGET}.tar.gz
# Rust's libraries are named librustc_${component}-${RUST_VSN_HASH}.so.
diff --git a/lang/rust/distinfo.amd64 b/lang/rust/distinfo.amd64
index 9f95bcd70625..22ee75f88214 100644
--- a/lang/rust/distinfo.amd64
+++ b/lang/rust/distinfo.amd64
@@ -1,5 +1,5 @@
-TIMESTAMP = 1468066508
-SHA256 (rustc-1.10.0-src.tar.gz) = a4015aacf4f6d8a8239253c4da46e7abaa8584f8214d1828d2ff0a8f56176869
-SIZE (rustc-1.10.0-src.tar.gz) = 25967780
-SHA256 (rustc-1.9.0-x86_64-unknown-freebsd.tar.gz) = 18f92b24d69ae2e5a542072e0f302f96ac1af096069a752833e9574d559e62ed
-SIZE (rustc-1.9.0-x86_64-unknown-freebsd.tar.gz) = 47969295
+TIMESTAMP = 1471599812
+SHA256 (rustc-1.11.0-src.tar.gz) = 3685034a78e70637bdfa3117619f759f2481002fd9abbc78cc0f737c9974de6a
+SIZE (rustc-1.11.0-src.tar.gz) = 26126471
+SHA256 (rustc-1.10.0-x86_64-unknown-freebsd.tar.gz) = 6271a638b02c1022e251c9e1d1fd78d1df4a73bdf0d20b25aa74548546037b84
+SIZE (rustc-1.10.0-x86_64-unknown-freebsd.tar.gz) = 48480245
diff --git a/lang/rust/distinfo.i386 b/lang/rust/distinfo.i386
index 81b90c02333f..8c203830131b 100644
--- a/lang/rust/distinfo.i386
+++ b/lang/rust/distinfo.i386
@@ -1,5 +1,5 @@
-TIMESTAMP = 1468066935
-SHA256 (rustc-1.10.0-src.tar.gz) = a4015aacf4f6d8a8239253c4da46e7abaa8584f8214d1828d2ff0a8f56176869
-SIZE (rustc-1.10.0-src.tar.gz) = 25967780
-SHA256 (rustc-1.9.0-i686-unknown-freebsd.tar.gz) = 7781f654405301292e17fbde635e770a1bc6620278e89cbd6d0dc4eaa7d8a6db
-SIZE (rustc-1.9.0-i686-unknown-freebsd.tar.gz) = 48830795
+TIMESTAMP = 1471599980
+SHA256 (rustc-1.11.0-src.tar.gz) = 3685034a78e70637bdfa3117619f759f2481002fd9abbc78cc0f737c9974de6a
+SIZE (rustc-1.11.0-src.tar.gz) = 26126471
+SHA256 (rustc-1.10.0-i686-unknown-freebsd.tar.gz) = 962b9c6d010355bd27e8d9bd56044f2a8ad79671bdce7955d15a201e88c139c1
+SIZE (rustc-1.10.0-i686-unknown-freebsd.tar.gz) = 49499375
diff --git a/lang/rust/files/patch-configure b/lang/rust/files/patch-configure
index 4b278fcb1c6b..4cac88fac1e2 100644
--- a/lang/rust/files/patch-configure
+++ b/lang/rust/files/patch-configure
@@ -1,10 +1,10 @@
---- configure.orig 2015-08-04 19:28:47 UTC
+--- configure.orig 2016-08-16 01:54:35 UTC
+++ configure
-@@ -696,7 +696,6 @@ putvar CFG_BOOTSTRAP_KEY
+@@ -726,7 +726,6 @@ if [ -n "$CFG_ENABLE_ORBIT" ]; then putv
step_msg "looking for build programs"
--probe_need CFG_CURLORWGET curl wget
+-probe_need CFG_CURL curl
if [ -z "$CFG_PYTHON_PROVIDED" ]; then
- probe_need CFG_PYTHON python2.7 python2.6 python2 python
+ probe_need CFG_PYTHON python2.7 python2 python
fi
diff --git a/lang/rust/files/patch-mk_rt.mk b/lang/rust/files/patch-mk_rt.mk
new file mode 100644
index 000000000000..ebcde6b96694
--- /dev/null
+++ b/lang/rust/files/patch-mk_rt.mk
@@ -0,0 +1,12 @@
+--- mk/rt.mk.orig 2016-07-17 07:06:29 UTC
++++ mk/rt.mk
+@@ -270,8 +270,7 @@ COMPRT_DEFINES_$(1) := -DCOMPILER_RT_ENA
+ endif
+
+ ifndef COMPRT_DIR_$(1)
+-# NB: FreeBSD and NetBSD output to "linux"...
+-COMPRT_DIR_$(1) := linux
++COMPRT_DIR_$(1) := $$(word 3, $$(subst -, , $(1)))
+ COMPRT_ARCH_$(1) := $$(patsubst i586,i386,$$(COMPRT_ARCH_$(1)))
+
+ ifeq ($$(findstring android,$(1)),android)
diff --git a/lang/rust/files/patch-src_compiler-rt_cmake_config-ix.cmake b/lang/rust/files/patch-src_compiler-rt_cmake_config-ix.cmake
new file mode 100644
index 000000000000..1f3e91a1fc58
--- /dev/null
+++ b/lang/rust/files/patch-src_compiler-rt_cmake_config-ix.cmake
@@ -0,0 +1,26 @@
+--- src/compiler-rt/cmake/config-ix.cmake.orig 2016-08-16 01:54:40 UTC
++++ src/compiler-rt/cmake/config-ix.cmake
+@@ -188,20 +188,9 @@ if(ANDROID)
+ set(COMPILER_RT_OS_SUFFIX "-android")
+ elseif(NOT APPLE) # Supported archs for Apple platforms are generated later
+ if("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "i[2-6]86|x86|amd64")
+- if(NOT MSVC)
+- test_target_arch(x86_64 "" "-m64")
+- # FIXME: We build runtimes for both i686 and i386, as "clang -m32" may
+- # target different variant than "$CMAKE_C_COMPILER -m32". This part should
+- # be gone after we resolve PR14109.
+- test_target_arch(i686 __i686__ "-m32")
+- test_target_arch(i386 __i386__ "-m32")
+- else()
+- if (CMAKE_SIZEOF_VOID_P EQUAL 4)
+- test_target_arch(i386 "" "")
+- else()
+- test_target_arch(x86_64 "" "")
+- endif()
+- endif()
++ test_target_arch(x86_64 "" "")
++ test_target_arch(i686 "" "")
++ test_target_arch(i386 "" "")
+ elseif("${COMPILER_RT_DEFAULT_TARGET_ARCH}" MATCHES "powerpc")
+ TEST_BIG_ENDIAN(HOST_IS_BIG_ENDIAN)
+ if(HOST_IS_BIG_ENDIAN)
diff --git a/lang/rust/files/patch-src_etc_get-stage0.py b/lang/rust/files/patch-src_etc_get-stage0.py
new file mode 100644
index 000000000000..d8b16b6ffcdd
--- /dev/null
+++ b/lang/rust/files/patch-src_etc_get-stage0.py
@@ -0,0 +1,14 @@
+--- src/etc/get-stage0.py.orig 2016-08-16 01:54:35 UTC
++++ src/etc/get-stage0.py
+@@ -31,9 +31,8 @@ def main(triple):
+ filename = 'rustc-{}-{}.tar.gz'.format(channel, triple)
+ url = 'https://static.rust-lang.org/dist/{}/{}'.format(date, filename)
+ dst = dl_dir + '/' + filename
+- if os.path.exists(dst):
+- os.unlink(dst)
+- bootstrap.get(url, dst)
++ if not os.path.exists(dst):
++ bootstrap.get(url, dst)
+
+ stage0_dst = triple + '/stage0'
+ if os.path.exists(stage0_dst):
diff --git a/lang/rust/pkg-plist b/lang/rust/pkg-plist
index 3343aad6736b..61cd0a2bbfe7 100644
--- a/lang/rust/pkg-plist
+++ b/lang/rust/pkg-plist
@@ -15,6 +15,7 @@ lib/librustc_const_eval-%%RUST_VSN_HASH%%.so
lib/librustc_const_math-%%RUST_VSN_HASH%%.so
lib/librustc_data_structures-%%RUST_VSN_HASH%%.so
lib/librustc_driver-%%RUST_VSN_HASH%%.so
+lib/librustc_errors-%%RUST_VSN_HASH%%.so
lib/librustc_incremental-%%RUST_VSN_HASH%%.so
lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/librustc_llvm-%%RUST_VSN_HASH%%.so
@@ -33,6 +34,7 @@ lib/libserialize-%%RUST_VSN_HASH%%.so
lib/libstd-%%RUST_VSN_HASH%%.so
lib/libsyntax-%%RUST_VSN_HASH%%.so
lib/libsyntax_ext-%%RUST_VSN_HASH%%.so
+lib/libsyntax_pos-%%RUST_VSN_HASH%%.so
lib/libterm-%%RUST_VSN_HASH%%.so
lib/libtest-%%RUST_VSN_HASH%%.so
lib/rustlib/components
@@ -70,6 +72,7 @@ lib/rustlib/%%RUST_TARGET%%/lib/librustc_const_eval-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_const_math-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_data_structures-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_driver-%%RUST_VSN_HASH%%.so
+lib/rustlib/%%RUST_TARGET%%/lib/librustc_errors-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_incremental-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_llvm-%%RUST_VSN_HASH%%.so
@@ -90,6 +93,7 @@ lib/rustlib/%%RUST_TARGET%%/lib/libstd-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libstd-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libsyntax-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libsyntax_ext-%%RUST_VSN_HASH%%.so
+lib/rustlib/%%RUST_TARGET%%/lib/libsyntax_pos-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libterm-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libterm-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libtest-%%RUST_VSN_HASH%%.rlib