aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2003-04-02 18:50:38 +0800
committernetchild <netchild@FreeBSD.org>2003-04-02 18:50:38 +0800
commitfe81117791ab37062781c1335c86094e93e46e6a (patch)
treefc7d1d0460e202a336c061cd58b769a862afb9ec /lang
parent579d07d0e3d249c31ea45037c2889313d3b3820b (diff)
downloadfreebsd-ports-gnome-fe81117791ab37062781c1335c86094e93e46e6a.tar.gz
freebsd-ports-gnome-fe81117791ab37062781c1335c86094e93e46e6a.tar.zst
freebsd-ports-gnome-fe81117791ab37062781c1335c86094e93e46e6a.zip
The new version of icc adds -I include paths before the standard include
path, thus adding a system path with -I results in not respecting the sunstitute headers. This results in problems because we have some important changes there. Parts of this commit where Submitted by: marius@alchemy.franken.de
Diffstat (limited to 'lang')
-rw-r--r--lang/icc/Makefile1
-rw-r--r--lang/icc/files/patch-ia32::bin::icc2
-rw-r--r--lang/icc/files/patch-ia32::bin::icpc2
-rw-r--r--lang/icc7/Makefile1
-rw-r--r--lang/icc7/files/patch-ia32::bin::icc2
-rw-r--r--lang/icc7/files/patch-ia32::bin::icpc2
6 files changed, 6 insertions, 4 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 0d5f6188479f..8fc2fa7af37b 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 7.1.006
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_p_${PORTVERSION}
diff --git a/lang/icc/files/patch-ia32::bin::icc b/lang/icc/files/patch-ia32::bin::icc
index 596787d71cc3..5f637a0b017d 100644
--- a/lang/icc/files/patch-ia32::bin::icc
+++ b/lang/icc/files/patch-ia32::bin::icc
@@ -74,7 +74,7 @@
+ set -- "$@" "$val1"
+ i=$(($i+1))
+ done
-+ exec ${PREFIX}/intel/compiler70/ia32/bin/iccbin "$@";
++ exec ${PREFIX}/intel/compiler70/ia32/bin/iccbin -I${PREFIX}/intel/compiler70/ia32/include -I${PREFIX}/intel/compiler70/ia32/include/substitute_headers "$@";
else
- exec -a "<INSTALLDIR>/compiler70/ia32/bin/icc" <INSTALLDIR>/compiler70/ia32/bin/iccbin;
+ exec ${PREFIX}/intel/compiler70/ia32/bin/iccbin;
diff --git a/lang/icc/files/patch-ia32::bin::icpc b/lang/icc/files/patch-ia32::bin::icpc
index a4cc5026d007..712e1925aea8 100644
--- a/lang/icc/files/patch-ia32::bin::icpc
+++ b/lang/icc/files/patch-ia32::bin::icpc
@@ -67,7 +67,7 @@
+ set -- "$@" "$val1"
+ i=$(($i+1))
+ done
-+ exec ${PREFIX}/intel/compiler70/ia32/bin/icpcbin "$@";
++ exec ${PREFIX}/intel/compiler70/ia32/bin/icpcbin -I${PREFIX}/intel/compiler70/ia32/include -I${PREFIX}/intel/compiler70/ia32/include/substitute_headers "$@";
else
- exec -a "<INSTALLDIR>/compiler70/ia32/bin/icpc" <INSTALLDIR>/compiler70/ia32/bin/icpcbin;
+ exec ${PREFIX}/intel/compiler70/ia32/bin/icpcbin;
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 0d5f6188479f..8fc2fa7af37b 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= icc
PORTVERSION= 7.1.006
+PORTREVISION= 1
CATEGORIES= lang linux devel
MASTER_SITES=
DISTNAME= l_cc_p_${PORTVERSION}
diff --git a/lang/icc7/files/patch-ia32::bin::icc b/lang/icc7/files/patch-ia32::bin::icc
index 596787d71cc3..5f637a0b017d 100644
--- a/lang/icc7/files/patch-ia32::bin::icc
+++ b/lang/icc7/files/patch-ia32::bin::icc
@@ -74,7 +74,7 @@
+ set -- "$@" "$val1"
+ i=$(($i+1))
+ done
-+ exec ${PREFIX}/intel/compiler70/ia32/bin/iccbin "$@";
++ exec ${PREFIX}/intel/compiler70/ia32/bin/iccbin -I${PREFIX}/intel/compiler70/ia32/include -I${PREFIX}/intel/compiler70/ia32/include/substitute_headers "$@";
else
- exec -a "<INSTALLDIR>/compiler70/ia32/bin/icc" <INSTALLDIR>/compiler70/ia32/bin/iccbin;
+ exec ${PREFIX}/intel/compiler70/ia32/bin/iccbin;
diff --git a/lang/icc7/files/patch-ia32::bin::icpc b/lang/icc7/files/patch-ia32::bin::icpc
index a4cc5026d007..712e1925aea8 100644
--- a/lang/icc7/files/patch-ia32::bin::icpc
+++ b/lang/icc7/files/patch-ia32::bin::icpc
@@ -67,7 +67,7 @@
+ set -- "$@" "$val1"
+ i=$(($i+1))
+ done
-+ exec ${PREFIX}/intel/compiler70/ia32/bin/icpcbin "$@";
++ exec ${PREFIX}/intel/compiler70/ia32/bin/icpcbin -I${PREFIX}/intel/compiler70/ia32/include -I${PREFIX}/intel/compiler70/ia32/include/substitute_headers "$@";
else
- exec -a "<INSTALLDIR>/compiler70/ia32/bin/icpc" <INSTALLDIR>/compiler70/ia32/bin/icpcbin;
+ exec ${PREFIX}/intel/compiler70/ia32/bin/icpcbin;