aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-03-29 05:18:20 +0800
committerdinoex <dinoex@FreeBSD.org>2003-03-29 05:18:20 +0800
commitff7722f882d5f432f76ceaec4b755377345fce89 (patch)
tree2a0b7d9664f757182f3a817fafa01355ba126daa /lang
parent0dfd31bdc6ac90bb5dd01454a8e6fffd2e4932be (diff)
downloadfreebsd-ports-gnome-ff7722f882d5f432f76ceaec4b755377345fce89.tar.gz
freebsd-ports-gnome-ff7722f882d5f432f76ceaec4b755377345fce89.tar.zst
freebsd-ports-gnome-ff7722f882d5f432f76ceaec4b755377345fce89.zip
- replace old port of libobjc
this depends now on lang/gcc32 using it as a master port. to build the needed version of libobjc.so
Diffstat (limited to 'lang')
-rw-r--r--lang/gnustep-objc/Makefile57
-rw-r--r--lang/gnustep-objc/distinfo1
-rw-r--r--lang/gnustep-objc/pkg-descr9
-rw-r--r--lang/gnustep-objc/pkg-plist16
4 files changed, 10 insertions, 73 deletions
diff --git a/lang/gnustep-objc/Makefile b/lang/gnustep-objc/Makefile
index 468c693462d2..eeccf37dae34 100644
--- a/lang/gnustep-objc/Makefile
+++ b/lang/gnustep-objc/Makefile
@@ -1,55 +1,18 @@
-# New ports collection makefile for: gnustep-objc
-# Date created: 17 April 2001
-# Whom: Thomas Gellekum <tg@FreeBSD.org>
+# New ports collection makefile for: gnustep-objc
+# Date created: 28.Mar.2003
+# Whom: dirk.meyer@dinoex.sub.org
#
# $FreeBSD$
#
-PORTNAME= gnustep-objc
-PORTVERSION= 1.2.2
-CATEGORIES= lang devel
-MASTER_SITES= ${MASTER_SITE_GNUSTEP} \
- ftp://ftp.gnustep.org/pub/gnustep/%SUBDIR%/
-MASTER_SITE_SUBDIR= libs
+MASTERDIR?= ${.CURDIR}/../../lang/gcc32
-MAINTAINER= dinoex@FreeBSD.org
-COMMENT= A snapshot of libobjc, meant to be used with GNUstep
+WANT_SHAREDLIBS= yes
+WANT_THREADS_SUPPORT= yes
+PKGNAMESUFFIX= -objc
-BUILD_DEPENDS= ${SYSTEMDIR}/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
- ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= ${SYSTEMDIR}/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 300000
-BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
-.endif
-
-PREFIX= ${LOCALBASE}/GNUstep
-USE_GMAKE= yes
-MAKEFILE= GNUmakefile
-ALL_TARGET=
-NO_MTREE= yes
-INSTALLS_SHLIB= yes
-NOT_FOR_ARCHS= ia64
-IGNORE= "This port is obsolete with gnustep-1.5.2"
-
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
+.if exists(${.CURDIR}/Makefile.local)
+.include "${.CURDIR}/Makefile.local"
.endif
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION} \
- MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
-
-SYSTEMDIR= ${LOCALBASE}/GNUstep/System
-
-do-build:
- (cd ${WRKSRC}; . ${SYSTEMDIR}/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
-
-do-install:
- @(cd ${WRKSRC}; . ${SYSTEMDIR}/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
-.include <bsd.port.post.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/lang/gnustep-objc/distinfo b/lang/gnustep-objc/distinfo
deleted file mode 100644
index bbabffd4df43..000000000000
--- a/lang/gnustep-objc/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (gnustep-objc-1.2.2.tar.gz) = e74e5daa58d88377f76d2b8a67ec8660
diff --git a/lang/gnustep-objc/pkg-descr b/lang/gnustep-objc/pkg-descr
deleted file mode 100644
index 267b7c2ce47d..000000000000
--- a/lang/gnustep-objc/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-GNUstep is a set of general-purpose Objective-C libraries based on the
-OpenStep standard developed by NeXT (now Apple) Inc. The libraries
-consist of everything from foundation classes, such as dictionaries and
-arrays, to GUI interface classes such as windows, sliders, buttons, etc.
-
-Please contact the GNUstep maintainers at <discussion@gnustep.org> in
-case of questions and help offers.
-
-WWW: http://www.gnustep.org/
diff --git a/lang/gnustep-objc/pkg-plist b/lang/gnustep-objc/pkg-plist
deleted file mode 100644
index e527b8a4c81d..000000000000
--- a/lang/gnustep-objc/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-System/Headers/objc/hash.h
-System/Headers/objc/objc-list.h
-System/Headers/objc/sarray.h
-System/Headers/objc/objc.h
-System/Headers/objc/objc-api.h
-System/Headers/objc/objc-decls.h
-System/Headers/objc/NXConstStr.h
-System/Headers/objc/Object.h
-System/Headers/objc/Protocol.h
-System/Headers/objc/encoding.h
-System/Headers/objc/typedstream.h
-System/Headers/objc/thr.h
-System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/libobjc.so
-System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/libobjc.so.%%MAJORVERSION%%
-System/Libraries/%%GNU_ARCH%%/%%OPSYS%%/libobjc.so.%%VERSION%%
-@dirrm System/Headers/objc