aboutsummaryrefslogtreecommitdiffstats
path: root/mail/anubis
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-08-01 02:52:14 +0800
committerijliao <ijliao@FreeBSD.org>2002-08-01 02:52:14 +0800
commit8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb (patch)
tree33a1fcf432fe9156abe0d116dd0fe671ce940efd /mail/anubis
parent231f8814a000d493f8d1a78300d070dfce8d102a (diff)
downloadfreebsd-ports-gnome-8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb.tar.gz
freebsd-ports-gnome-8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb.tar.zst
freebsd-ports-gnome-8ab9ee28ec1a6b68b8f687b5becebc35bbdbd2fb.zip
add anubis 3.3.0
An outgoing mail processor
Diffstat (limited to 'mail/anubis')
-rw-r--r--mail/anubis/Makefile43
-rw-r--r--mail/anubis/distinfo1
-rw-r--r--mail/anubis/files/anubis.sh15
-rw-r--r--mail/anubis/pkg-comment1
-rw-r--r--mail/anubis/pkg-descr10
-rw-r--r--mail/anubis/pkg-plist8
6 files changed, 78 insertions, 0 deletions
diff --git a/mail/anubis/Makefile b/mail/anubis/Makefile
new file mode 100644
index 000000000000..f17a0c60fe90
--- /dev/null
+++ b/mail/anubis/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: anubis
+# Date created: Jul 31, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= anubis
+PORTVERSION= 3.3.0
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
+ pcre:${PORTSDIR}/devel/pcre \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_REINPLACE= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+
+MAN1= anubis.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/etc|${PREFIX}/etc|g" ${WRKSRC}/src/headers.h
+ @${SED} -e "s|%%PREFIX%%|${PREFIX}|g" ${FILESDIR}/anubis.sh > \
+ ${WRKSRC}/anubis.sh
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/anubis.sh ${PREFIX}/etc/rc.d
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/TUTORIAL ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/anubis/distinfo b/mail/anubis/distinfo
new file mode 100644
index 000000000000..d949c8d8097f
--- /dev/null
+++ b/mail/anubis/distinfo
@@ -0,0 +1 @@
+MD5 (anubis-3.3.0.tar.gz) = 0e885738683a69dbe9fcfce698ef0d7a
diff --git a/mail/anubis/files/anubis.sh b/mail/anubis/files/anubis.sh
new file mode 100644
index 000000000000..4404db4cf427
--- /dev/null
+++ b/mail/anubis/files/anubis.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ [ -x %%PREFIX%%/sbin/anubis ] && %%PREFIX%%/sbin/anubis > /dev/null && echo -n ' anubis'
+ ;;
+stop)
+ killall anubis
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/mail/anubis/pkg-comment b/mail/anubis/pkg-comment
new file mode 100644
index 000000000000..6480bcfc6434
--- /dev/null
+++ b/mail/anubis/pkg-comment
@@ -0,0 +1 @@
+An outgoing mail processor
diff --git a/mail/anubis/pkg-descr b/mail/anubis/pkg-descr
new file mode 100644
index 000000000000..11a1ee532022
--- /dev/null
+++ b/mail/anubis/pkg-descr
@@ -0,0 +1,10 @@
+Anubis is an outgoing mail processor, and provides the SMTP tunnel between
+the MUA (Mail User Agent) and the MTA (Mail Transport Agent). It operates
+as a proxy server daemon, independently from mail user agents, and can manage
+and process outgoing mail on the fly using a highly configurable rule system,
+based on a regular expressions (PerlRE) system. Anubis can edit outgoing mail
+headers, encrypt and/or sign mail with GnuPG, build secure SMTP tunnels using
+the TLS/SSL encryption even if your mail user agent doesn't support it, or
+tunnel a connection through a SOCKS proxy server.
+
+WWW: http://anubis.sourceforge.net/
diff --git a/mail/anubis/pkg-plist b/mail/anubis/pkg-plist
new file mode 100644
index 000000000000..846a9d1ee20e
--- /dev/null
+++ b/mail/anubis/pkg-plist
@@ -0,0 +1,8 @@
+sbin/anubis
+etc/rc.d/anubis.sh
+%%PORTDOCS%%share/doc/anubis/TUTORIAL
+%%PORTDOCS%%@dirrm share/doc/anubis
+%%PORTDOCS%%share/examples/anubis/1anubisrc
+%%PORTDOCS%%share/examples/anubis/2anubisrc
+%%PORTDOCS%%share/examples/anubis/defaultrc
+%%PORTDOCS%%@dirrm share/examples/anubis