aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-12-10 23:30:08 +0800
committerwxs <wxs@FreeBSD.org>2009-12-10 23:30:08 +0800
commit54a9cc2853d4ddcd96b276ddedcf372b9c87c106 (patch)
tree767507acab562401d9bd64accdc54b2bd36112dd /mail/dovecot/Makefile
parent661148485ac047bf795e73fee068005f804210dc (diff)
downloadfreebsd-ports-gnome-54a9cc2853d4ddcd96b276ddedcf372b9c87c106.tar.gz
freebsd-ports-gnome-54a9cc2853d4ddcd96b276ddedcf372b9c87c106.tar.zst
freebsd-ports-gnome-54a9cc2853d4ddcd96b276ddedcf372b9c87c106.zip
- Update to 1.2.8
PR: ports/139386 Submitted by: Sahil Tandon <sahil@tandon.net> Approved by: Yarema <yds@CoolRat.org> (maintainer)
Diffstat (limited to 'mail/dovecot/Makefile')
-rw-r--r--mail/dovecot/Makefile21
1 files changed, 3 insertions, 18 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 887c7dcf2f7e..cbb3fbb16789 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= dovecot
-PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTVERSION= 1.2.8
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${DOVECOTVERSION}/ \
http://www.rename-it.nl/dovecot/${DOVECOTVERSION}/
@@ -52,12 +51,11 @@ PORTDOCS= *.txt wiki ${DOCS}
DOVECOT_UID?= 143
DOVECOT_GID?= 143
-PROTOCOLS= imap
+PROTOCOLS= imap pop3
OPTIONS= KQUEUE "kqueue(2) support" on \
SSL "SSL support" on \
IPV6 "IPv6 support" on \
- POP3 "POP3 support" on \
LDA "LDA support" on \
MANAGESIEVE "ManageSieve support" on \
GSSAPI "GSSAPI support" off \
@@ -91,7 +89,7 @@ CONFIGURE_ARGS+= --with-ioloop=kqueue
## SSL support
#
.if defined(WITH_SSL) && !defined(WITHOUT_SSL)
-PROTOCOLS+= imaps
+PROTOCOLS+= imaps pop3s
.else
CONFIGURE_ARGS+= --without-ssl
.endif
@@ -102,19 +100,6 @@ CONFIGURE_ARGS+= --without-ssl
CONFIGURE_ARGS+= --disable-ipv6
.endif
-## POP3 support
-#
-.if defined(WITHOUT_POP3)
-CONFIGURE_ARGS+= --without-pop3d
-PLIST_SUB+= POP3="@comment "
-.else
-PROTOCOLS+= pop3
-.if defined(WITH_SSL) && !defined(WITHOUT_SSL)
-PROTOCOLS+= pop3s
-.endif
-PLIST_SUB+= POP3=""
-.endif
-
## LDA support
#
.if defined(WITHOUT_LDA)