aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot2/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-10-26 08:15:42 +0800
committeradamw <adamw@FreeBSD.org>2014-10-26 08:15:42 +0800
commit60f213330b19915c6e3a54abd542a36c93e65ce0 (patch)
tree391311a06c8bdb0d799ac4259497347d516bfd9f /mail/dovecot2/Makefile
parentc525d6b0ca2b4ba8e23d1e2d16066ea08c551a09 (diff)
downloadfreebsd-ports-gnome-60f213330b19915c6e3a54abd542a36c93e65ce0.tar.gz
freebsd-ports-gnome-60f213330b19915c6e3a54abd542a36c93e65ce0.tar.zst
freebsd-ports-gnome-60f213330b19915c6e3a54abd542a36c93e65ce0.zip
Update dovecot2 to 2.2.15, and add an LZ4 option that uses liblz4.
ChangeLog: Some small fixes and changes to v2.2.14. This release is mainly in the hope that it could still make it into the next Debian stable instead of v2.2.14 - mainly because of a couple of new assert crashes that started happening in v2.2.14 and should be fixed now. * Plugins can now print a banner comment in doveconf output (typically the plugin version) * Replication plugin now triggers low (instead of high) priority for mail copying operations. * IMAP/POP3/ManageSieve proxy: If destination server can't be connected to, retry connecting once per second up to the value of proxy_timeout. This allows quick restarts/upgrades on the backend server without returning login failures. * Internal passdb lookups (e.g. done by lmtp/doveadm proxy) wasn't returning failure in some situations where it should have (e.g. allow_nets mismatch) * LMTP uses mail_log_prefix now for logging mail deliveries instead of a hardcoded prefix. The non-delivery log prefix is still hardcoded though. + passdb allow_nets=local matches lookups that don't contain an IP address (internally done by Dovecot services) + Various debug logging and error logging improvements - Various race condition fixes to LAYOUT=index - v2.2.14 virtual plugin crashed in some situations
Diffstat (limited to 'mail/dovecot2/Makefile')
-rw-r--r--mail/dovecot2/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index c86835174a7b..3ce44376ef3a 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dovecot
-PORTVERSION= 2.2.14
-PORTREVISION= 1
+PORTVERSION= 2.2.15
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
@@ -36,16 +35,13 @@ CONFIGURE_ARGS= --localstatedir=/var \
--with-statedir=/var/db/dovecot \
--without-shadow
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
USE_LDCONFIG= ${PREFIX}/lib/dovecot
INSTALL_TARGET= install-strip
USERS= dovecot dovenull
GROUPS= ${USERS}
-OPTIONS_DEFINE= KQUEUE SSL VPOPMAIL LDAP LUCENE PGSQL MYSQL SQLITE \
+OPTIONS_DEFINE= KQUEUE SSL VPOPMAIL LDAP LUCENE LZ4 PGSQL MYSQL SQLITE \
SOLR DOCS EXAMPLES LIBWRAP
OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_NONE GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
@@ -53,9 +49,10 @@ OPTIONS_DEFAULT=KQUEUE SSL GSSAPI_NONE
OPTIONS_SUB= yes
KQUEUE_DESC= kqueue(2) support
-VPOPMAIL_DESC= vpopmail support
LUCENE_DESC= CLucene FTS support
+LZ4_DESC= LZ4 compression support
SOLR_DESC= Solr FTS support
+VPOPMAIL_DESC= vpopmail support
GSSAPI_NONE_DESC= Build without GSSAPI support
GSSAPI_BASE_DESC= Use GSSAPI from base
@@ -84,6 +81,8 @@ LIBWRAP_CONFIGURE_WITH= libwrap
LUCENE_CONFIGURE_WITH= lucene
LUCENE_LIB_DEPENDS= libclucene-core.so:${PORTSDIR}/textproc/clucene
+LZ4_LIB_DEPENDS= liblz4.so:${PORTSDIR}/archivers/liblz4
+
MYSQL_USE= MYSQL=yes
MYSQL_CONFIGURE_WITH= mysql
MYSQL_RC_REQUIRE= mysql
@@ -114,6 +113,9 @@ PORTEXAMPLES= *
BROKEN= Does not build on arm
.endif
+CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
+LDFLAGS+= -L${LOCALBASE}/lib -I${OPENSSLLIB}
+
# Default requirement for dovecot rc script
_REQUIRE= LOGIN