aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot2/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-25 01:38:34 +0800
committeradamw <adamw@FreeBSD.org>2015-03-25 01:38:34 +0800
commit82dcc63be22ffaa82efacf25b0c0df7c9473c262 (patch)
treed254fb7944cc94e581d90091fa9b787d6470818a /mail/dovecot2/Makefile
parentae02fab82d63b0e67901cb320c5e9bf4ddd64018 (diff)
downloadfreebsd-ports-gnome-82dcc63be22ffaa82efacf25b0c0df7c9473c262.tar.gz
freebsd-ports-gnome-82dcc63be22ffaa82efacf25b0c0df7c9473c262.tar.zst
freebsd-ports-gnome-82dcc63be22ffaa82efacf25b0c0df7c9473c262.zip
Move the sample configuration files into ETCDIR.
After talking more with Rozhuk Ivan (submitter of 198792, see r381930), the sample configuration files don't belong in DOCSDIR, and they really don't belong underneath an OPTION that many people have disabled by default. I still don't think that they're good candidates for @sample, but they make more sense living in ETCDIR. While here, shuffle around a few other docs/examples files. PORTREVISION bump for the plist changes. PR: 198792 Submitted by: Rozhuk Ivan
Diffstat (limited to 'mail/dovecot2/Makefile')
-rw-r--r--mail/dovecot2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index af6f17521673..2e88438a06a3 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dovecot
PORTVERSION= 2.2.16
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
@@ -128,11 +129,15 @@ post-patch:
${WRKSRC}/doc/example-config/*.conf ${WRKSRC}/doc/example-config/conf.d/*
@${REINPLACE_CMD} -e '/^LIBS =/s/$$/ @LTLIBICONV@/' \
${WRKSRC}/src/lib-mail/Makefile.in
+ # Install the sample config files into ETCDIR/example-config/
+ @${REINPLACE_CMD} -e '/^exampledir =/s|\$$(docdir)|${ETCDIR}|' \
+ ${WRKSRC}/doc/example-config/Makefile.in \
+ ${WRKSRC}/doc/example-config/conf.d/Makefile.in
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/doc/mkcert.sh ${STAGEDIR}${EXAMPLESDIR}
+ ${MV} ${STAGEDIR}${DOCSDIR}/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
+ ${MV} ${STAGEDIR}${DOCSDIR}/mkcert.sh ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>