aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot2/Makefile
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-01 05:06:53 +0800
committeradamw <adamw@FreeBSD.org>2014-07-01 05:06:53 +0800
commitbf9f2b632b12dd231129bb0ce873cd9be7c0a245 (patch)
tree5ba214145b9dc977a6218c9b0a05719f1d0cf75f /mail/dovecot2/Makefile
parent8302696327992023af842a5bf95253cdd005957e (diff)
downloadfreebsd-ports-gnome-bf9f2b632b12dd231129bb0ce873cd9be7c0a245.tar.gz
freebsd-ports-gnome-bf9f2b632b12dd231129bb0ce873cd9be7c0a245.tar.zst
freebsd-ports-gnome-bf9f2b632b12dd231129bb0ce873cd9be7c0a245.zip
General tidying and cleanups. THe functional changes:
Remove NOOP sed commands, and incorporate the pkg-deinstall message into pkg-plist. Use install-strip as the INSTALL_TARGET rather than manually stripping libraries. Technically it needs a PORTREVISION bump for the pkg-deinstall/pkg-plist thing, but I'm going to need to bump PORTREVISION for some other changes soon and I'd rather not force everyone to rebuild an extra time for a differently-phrased message.
Diffstat (limited to 'mail/dovecot2/Makefile')
-rw-r--r--mail/dovecot2/Makefile61
1 files changed, 24 insertions, 37 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index b6ca49462217..3e31217033d0 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -30,7 +30,6 @@ USES= iconv
USE_RC_SUBR= dovecot
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --localstatedir=/var \
--with-statedir=/var/db/dovecot \
--without-shadow
@@ -39,61 +38,67 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= ${PREFIX}/lib/dovecot
+INSTALL_TARGET= install-strip
USERS= dovecot dovenull
GROUPS= ${USERS}
-PROTOCOLS= imap pop3
-
# Default requirement for dovecot rc script
_REQUIRE= LOGIN
OPTIONS_DEFINE= KQUEUE SSL GSSAPI VPOPMAIL LDAP LUCENE PGSQL MYSQL SQLITE \
SOLR DOCS EXAMPLES LIBWRAP
-OPTIONS_DEFAULT= KQUEUE SSL
+OPTIONS_DEFAULT=KQUEUE SSL
+OPTIONS_SUB= yes
KQUEUE_DESC= kqueue(2) support
VPOPMAIL_DESC= vpopmail support
LUCENE_DESC= CLucene FTS support
SOLR_DESC= Solr FTS support
-OPTIONS_SUB= yes
DOCS_CONFIGURE_WITH= docs
+
GSSAPI_CONFIGURE_WITH= gssapi
GSSAPI_LDFLAGS= -lgssapi_krb5
+
KQUEUE_CONFIGURE_OFF= --with-ioloop=poll
KQUEUE_CONFIGURE_ON= --with-ioloop=kqueue
+
LDAP_CONFIGURE_WITH= ldap
LDAP_USE= OPENLDAP=yes
+
LIBWRAP_CONFIGURE_WITH= libwrap
+
LUCENE_CONFIGURE_WITH= lucene
LUCENE_LIB_DEPENDS= libclucene-core.so:${PORTSDIR}/textproc/clucene
+
MYSQL_CONFIGURE_WITH= mysql
MYSQL_USE= MYSQL=yes
+
PGSQL_CONFIGURE_WITH= pgsql
PGSQL_USE= PGSQL=yes
+
SOLR_BUILD_DEPENDS= curl:${PORTSDIR}/ftp/curl
SOLR_CONFIGURE_WITH= solr
SOLR_LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+
SQLITE_CONFIGURE_WITH= sqlite
SQLITE_USE= SQLITE=3
+
SSL_CONFIGURE_OFF= --without-ssl
SSL_CONFIGURE_ON= --with-ssl=openssl
+
VPOPMAIL_BUILD_DEPENDS= ${LOCALBASE}/vpopmail/bin/vchkpw:${PORTSDIR}/mail/vpopmail
VPOPMAIL_CONFIGURE_WITH=vpopmail
-.include <bsd.port.options.mk>
-
-.if ${ARCH} == "arm"
-BROKEN= Does not build on arm
-.endif
-
DOCS= AUTHORS COPYING COPYING.LGPL COPYING.MIT INSTALL NEWS TODO README
PORTDOCS= *
PORTEXAMPLES= *
-.if ${PORT_OPTIONS:MSSL}
-PROTOCOLS+= imaps pop3s
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == "arm"
+BROKEN= Does not build on arm
.endif
.if ${PORT_OPTIONS:MLDAP}
@@ -109,35 +114,17 @@ _REQUIRE+= mysql
.endif
SUB_LIST+= REQUIRE="${_REQUIRE}"
-SUB_FILES+= pkg-deinstall pkg-message
-
-# sed script for dovecot.conf
-REINPLACE= s!%%PROTOCOLS%%!${PROTOCOLS}!g;\
- s!/usr/!${PREFIX}/!g;\
- s!=/usr!=${PREFIX}!g;\
- s!=/etc !=${PREFIX}/etc !g;\
- s!/etc/dovecot!${PREFIX}&!g;\
- s![[:<:]]doc/(dovecot-[^-]+)-example.conf[[:>:]]!${EXAMPLESDIR}/\1.conf!g;\
- s!\#sendmail_path = /usr/.*!sendmail_path = /usr/sbin/sendmail!g;
+SUB_FILES+= pkg-message
post-patch:
- @${REINPLACE_CMD} -E -e '${REINPLACE}' \
- ${WRKSRC}/doc/example-config/dovecot.conf
- @${REINPLACE_CMD} -E -e'\
- s!-example\.conf[[:>:]]!.conf!g;\
- s!^(confdir[[:space:]]+=[[:space:]]+)\$$\(sysconfdir\)!\1${EXAMPLESDIR}!g;\
- ' ${WRKSRC}/*/Makefile.in ${WRKSRC}/Makefile.in
-# exclude this file
- ${REINPLACE_CMD} -e '/2b/d' ${WRKSRC}/doc/wiki/Makefile.in
+ @${REINPLACE_CMD} -e 's,/etc/dovecot,${PREFIX}/etc/dovecot,g; \
+ s,sysconfdir=/etc,sysconfdir=${PREFIX}/etc,g' \
+ ${WRKSRC}/doc/example-config/*.conf ${WRKSRC}/doc/example-config/conf.d/*
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/doc && ${INSTALL_SCRIPT} dovecot-openssl.cnf mkcert.sh ${STAGEDIR}${EXAMPLESDIR})
-.if ${PORT_OPTIONS:MDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/doc/mkcert.sh ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dovecot/lib*.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dovecot/auth/lib*.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dovecot/doveadm/lib*.so
.include <bsd.port.mk>