aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot2
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-07-06 03:31:37 +0800
committerAdam Weinberger <adamw@FreeBSD.org>2016-07-06 03:31:37 +0800
commit45beea60f899ce729eb5114096721c723749889b (patch)
tree6547c729ab1bb86cee8e8d108b5e07f9aa25e4d7 /mail/dovecot2
parent2ae74cd36844f939a5dc6c8b6a708551c93c5b95 (diff)
downloadfreebsd-ports-gnome-45beea60f899ce729eb5114096721c723749889b.tar.gz
freebsd-ports-gnome-45beea60f899ce729eb5114096721c723749889b.tar.zst
freebsd-ports-gnome-45beea60f899ce729eb5114096721c723749889b.zip
Fix build on 9.x.
Adds compiler:c11 for this error: sha1.h:80: error: static or type qualifiers in abstract declarator dovecot no longer builds againt the old OpenSSL in 9.x base, so require ssl from ports there. Despite the dependency change (only for 9.x), I'm not bumping PORTREVISION because build couldn't complete on 9.x regardless.
Diffstat (limited to 'mail/dovecot2')
-rw-r--r--mail/dovecot2/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 63611734e83e..a12cc8a052ca 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -135,6 +135,13 @@ PGSQL_VARS= _REQUIRE+=postgresql
SUB_LIST+= REQUIRE="${_REQUIRE}"
SUB_FILES+= pkg-message
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} < 1000011
+USES+= compiler:c11
+WITH_OPENSSL_PORT= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
CPPFLAGS+= -I${LOCALBASE}/include -I${OPENSSLINC}
LDFLAGS+= -L${LOCALBASE}/lib -I${OPENSSLLIB}
@@ -160,4 +167,4 @@ post-install-EXAMPLES-on:
${MV} ${STAGEDIR}${DOCSDIR}/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
${MV} ${STAGEDIR}${DOCSDIR}/mkcert.sh ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>