aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot2
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-10-12 05:59:38 +0800
committerAdam Weinberger <adamw@FreeBSD.org>2016-10-12 05:59:38 +0800
commitff2359b50663ba8f94cd13c3b6ec247320b596e1 (patch)
tree94aae0cc27c120a35fa3dcd3d8f8ba20b9e51466 /mail/dovecot2
parent2b87141861cd4cc43b2c3230ecc9cbbe5c07a7c1 (diff)
downloadfreebsd-ports-gnome-ff2359b50663ba8f94cd13c3b6ec247320b596e1.tar.gz
freebsd-ports-gnome-ff2359b50663ba8f94cd13c3b6ec247320b596e1.tar.zst
freebsd-ports-gnome-ff2359b50663ba8f94cd13c3b6ec247320b596e1.zip
- When DOCS is enabled but EXAMPLES is not, two files that are supposed to
be examples are bundled into DOCSDIR. Fix this by installing them into EXAMPLESDIR regardless of the EXAMPLES knob and trust pkg to DTRT - Make vpopmail depend on vpopmail-the-package, instead of vchkpw-the-silly-looking-path-under-LOCALBASE - Turn the curl dependency in the SOLR knob to a LIB_DEPENDS instead of a BUILD_DEPENDS, so that curl is available at runtime as well - Categorize the OPTIONS helpers under the same categories they're listed under in the OPTIONS dialogue, to aid with organization PORTREVISION bump for the potential plist and dependency changes.
Diffstat (limited to 'mail/dovecot2')
-rw-r--r--mail/dovecot2/Makefile66
1 files changed, 35 insertions, 31 deletions
diff --git a/mail/dovecot2/Makefile b/mail/dovecot2/Makefile
index 8ed9b0dd9e81..d297c36d93c2 100644
--- a/mail/dovecot2/Makefile
+++ b/mail/dovecot2/Makefile
@@ -14,7 +14,7 @@
PORTNAME= dovecot
PORTVERSION= 2.2.25
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/${PORTVERSION:R}/
PKGNAMESUFFIX= 2
@@ -72,50 +72,54 @@ GSSAPI_BASE_DESC= Use GSSAPI from base
GSSAPI_HEIMDAL_DESC= Use Heimdal GSSAPI from security/heimdal
GSSAPI_MIT_DESC= Use MIT GSSAPI from security/krb5
-CDB_CONFIGURE_WITH= cdb
-CDB_LIB_DEPENDS= libcdb.so:databases/tinycdb
-
-GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
-GSSAPI_NONE_CONFIGURE_OFF= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
-GSSAPI_BASE_USES= gssapi
-GSSAPI_HEIMDAL_USES= gssapi:heimdal
-GSSAPI_MIT_USES= gssapi:mit
-
-ICU_CONFIGURE_WITH= icu
-ICU_LIB_DEPENDS= libicui18n.so:devel/icu
-ICU_USES= pkgconfig
-
+# General options
KQUEUE_CONFIGURE_OFF= --with-ioloop=poll --with-notify=none
KQUEUE_CONFIGURE_ON= --with-ioloop=kqueue --with-notify=kqueue
-LDAP_USE= OPENLDAP=yes
-LDAP_CONFIGURE_WITH= ldap
-
LIBWRAP_CONFIGURE_WITH= libwrap
-LUCENE_CONFIGURE_WITH= lucene
-LUCENE_LIB_DEPENDS= libclucene-core.so:textproc/clucene
-
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
+VPOPMAIL_BUILD_DEPENDS= vpopmail>=0:mail/vpopmail
+VPOPMAIL_CONFIGURE_WITH=vpopmail
+
+# Databases
+CDB_CONFIGURE_WITH= cdb
+CDB_LIB_DEPENDS= libcdb.so:databases/tinycdb
+
+LDAP_USE= OPENLDAP=yes
+LDAP_CONFIGURE_WITH= ldap
+
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql
-SOLR_CONFIGURE_WITH= solr
-SOLR_BUILD_DEPENDS= curl:ftp/curl
-SOLR_LIB_DEPENDS= libexpat.so:textproc/expat2
-
SQLITE_USES= sqlite:3
SQLITE_CONFIGURE_WITH= sqlite
+# FTS
+ICU_CONFIGURE_WITH= icu
+ICU_LIB_DEPENDS= libicui18n.so:devel/icu
+ICU_USES= pkgconfig
+
+LUCENE_CONFIGURE_WITH= lucene
+LUCENE_LIB_DEPENDS= libclucene-core.so:textproc/clucene
+
+SOLR_CONFIGURE_WITH= solr
+SOLR_LIB_DEPENDS= libcurl.so:ftp/curl \
+ libexpat.so:textproc/expat2
+
TEXTCAT_CONFIGURE_WITH= textcat
TEXTCAT_LIB_DEPENDS= libtextcat.so:textproc/libtextcat
-VPOPMAIL_BUILD_DEPENDS= ${LOCALBASE}/vpopmail/bin/vchkpw:mail/vpopmail
-VPOPMAIL_CONFIGURE_WITH=vpopmail
+# GSSAPI
+GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
+GSSAPI_NONE_CONFIGURE_OFF= --with-gssapi ${GSSAPI_CONFIGURE_ARGS}
+GSSAPI_BASE_USES= gssapi
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_MIT_USES= gssapi:mit
DOCS= AUTHORS COPYING COPYING.LGPL COPYING.MIT INSTALL NEWS TODO README
PORTDOCS= *
@@ -156,13 +160,13 @@ post-patch:
@${REINPLACE_CMD} -e '/^[^#]/s|/usr|${LOCALBASE}|' \
${WRKSRC}/src/plugins/fts/decode2text.sh
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
-
-post-install-EXAMPLES-on:
+post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${MV} ${STAGEDIR}${DOCSDIR}/dovecot-openssl.cnf ${STAGEDIR}${EXAMPLESDIR}
${MV} ${STAGEDIR}${DOCSDIR}/mkcert.sh ${STAGEDIR}${EXAMPLESDIR}
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
+
.include <bsd.port.post.mk>