aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dovecot
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-09-24 20:31:29 +0800
committerpav <pav@FreeBSD.org>2006-09-24 20:31:29 +0800
commitb1ceeaff177a950da5f8372cc4a67f4c24f37762 (patch)
treef1d3025adb8e083369d6ca6bf87af74617cba9ff /mail/dovecot
parent108a6a9dec8cdbf440c3ffebb251b8475366a1b1 (diff)
downloadfreebsd-ports-gnome-b1ceeaff177a950da5f8372cc4a67f4c24f37762.tar.gz
freebsd-ports-gnome-b1ceeaff177a950da5f8372cc4a67f4c24f37762.tar.zst
freebsd-ports-gnome-b1ceeaff177a950da5f8372cc4a67f4c24f37762.zip
- Fix 100% CPU usage looping when a vnode change event came but it was never
untriggered. Patch by Rui Lopes PR: ports/103525 Submitted by: Robin Breathe <robin@isometry.net> (maintainer)
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile1
-rw-r--r--mail/dovecot/files/patch-src_lib_ioloop-notify-kqueue.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 2854bd13ea6d..6c6e7401facd 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dovecot
DISTVERSION= 1.0.rc7
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= http://www.dovecot.org/releases/
diff --git a/mail/dovecot/files/patch-src_lib_ioloop-notify-kqueue.c b/mail/dovecot/files/patch-src_lib_ioloop-notify-kqueue.c
new file mode 100644
index 000000000000..bdf3f6d75899
--- /dev/null
+++ b/mail/dovecot/files/patch-src_lib_ioloop-notify-kqueue.c
@@ -0,0 +1,14 @@
+--- src/lib/ioloop-notify-kqueue.c 16 Aug 2006 17:58:03 -0000 1.3.2.2
++++ src/lib/ioloop-notify-kqueue.c 26 Aug 2006 13:55:01 -0000 1.3.2.3
+@@ -111,7 +111,10 @@
+ io->callback = callback;
+ io->context = context;
+
+- EV_SET(&ev, fd, EVFILT_VNODE, EV_ADD,
++ /* EV_CLEAR flag is needed because the EVFILT_VNODE filter reports
++ event state transitions and not the current state. With this flag,
++ the same event is only returned once. */
++ EV_SET(&ev, fd, EVFILT_VNODE, EV_ADD | EV_CLEAR,
+ NOTE_DELETE | NOTE_WRITE | NOTE_EXTEND | NOTE_REVOKE, 0, io);
+ if (kevent(ctx->kq, &ev, 1, NULL, 0, NULL) < 0) {
+ i_error("kevent(%d, %s) for notify failed: %m", fd, path);