aboutsummaryrefslogtreecommitdiffstats
path: root/mail/dspam/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
committermat <mat@FreeBSD.org>2016-10-21 23:21:13 +0800
commit60e51bda11dcc0742419f2a459990d0d81cb07d8 (patch)
treea5029ff30555b3a7ee0621f4dd5aacb832fde1d8 /mail/dspam/Makefile
parent3432585b4743642027fc2b3af5eac2780fc2c4cd (diff)
downloadfreebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.gz
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.tar.zst
freebsd-ports-gnome-60e51bda11dcc0742419f2a459990d0d81cb07d8.zip
Use USES=pathfix where applicable.
PR: 213195 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D8093
Diffstat (limited to 'mail/dspam/Makefile')
-rw-r--r--mail/dspam/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index aa588640fe88..d62c4b8bca1a 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -76,7 +76,7 @@ LIGHTTPD_DESC= RUN_DEPEND on Lighttpd instead of Apache
SETUID_DESC= Run as root:mail with setuid (insecure)
MAKE_JOBS_UNSAFE= yes
-USES= perl5 libtool shebangfix
+USES= perl5 libtool pathfix shebangfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -512,13 +512,6 @@ pre-configure:
.endif
post-install:
-########
-# stupid hack until I figure out where/how to patch
- @${MKDIR} ${STAGEDIR}${PREFIX}/libdata/pkgconfig
- ${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig/dspam.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig/dspam.pc
- ${TEST} `ls -1 ${STAGEDIR}${PREFIX}/lib/pkgconfig | wc -l` -eq 0 && \
- ${RM} -R ${STAGEDIR}${PREFIX}/lib/pkgconfig || true
-
.if ${PORT_OPTIONS:MEXAMPLES}
.if ${PORT_OPTIONS:MMYSQL}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/mysql