aboutsummaryrefslogtreecommitdiffstats
path: root/mail/enma/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-08-14 00:14:12 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-08-14 00:14:12 +0800
commit00885ca318ba643948c23eff484c8a37389c6dc9 (patch)
tree998b81893b255e4835996505ef777dc592d1674a /mail/enma/Makefile
parent9d03984c50d0889f041fff6a978983bf0b619205 (diff)
downloadfreebsd-ports-gnome-00885ca318ba643948c23eff484c8a37389c6dc9.tar.gz
freebsd-ports-gnome-00885ca318ba643948c23eff484c8a37389c6dc9.tar.zst
freebsd-ports-gnome-00885ca318ba643948c23eff484c8a37389c6dc9.zip
- Switch to USES=libtool, drop .la files
- Strip libraries - Clarify LICENSE - Fix GNU_CONFIGURE misuse
Diffstat (limited to 'mail/enma/Makefile')
-rw-r--r--mail/enma/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index 3e57c80d44b8..4ce9469ad0e1 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -10,19 +10,17 @@ MASTER_SITES= SF/${PORTNAME}/ENMA/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Sender authentication milter supporting SPF and Sender ID
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= LIBBIND
LIBBIND_DESC= Link against dns/libbind instead of dns/ldns
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --mandir=${PREFIX}/man \
- --with-ssl-incdir=${OPENSSLINC} \
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ssl-incdir=${OPENSSLINC} \
--with-ssl-libdir=${OPENSSLLIB}
-USES= gmake perl5
+USES= gmake libtool perl5
USE_RC_SUBR= milter-enma
USE_LDCONFIG= yes
USE_OPENSSL= yes
@@ -68,5 +66,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
. endfor
.endif
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sidfquery \
+ ${STAGEDIR}${PREFIX}/lib/libsauth.so \
+ ${STAGEDIR}${PREFIX}/libexec/enma
.include <bsd.port.mk>