aboutsummaryrefslogtreecommitdiffstats
path: root/mail/enma/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-08 23:04:43 +0800
committermarino <marino@FreeBSD.org>2014-07-08 23:04:43 +0800
commitbfbebcb76dbf47d03f400e14e1440e6eac27024f (patch)
treedf7ab844322c850e724537c65929fe4a3349704e /mail/enma/Makefile
parenta20ed062e56e6302ab7084fc75be6c7a987e5454 (diff)
downloadfreebsd-ports-gnome-bfbebcb76dbf47d03f400e14e1440e6eac27024f.tar.gz
freebsd-ports-gnome-bfbebcb76dbf47d03f400e14e1440e6eac27024f.tar.zst
freebsd-ports-gnome-bfbebcb76dbf47d03f400e14e1440e6eac27024f.zip
mail/enma: stage, explicit linking to libssl (dports)
While here: * convert from PLIST to pkg-plist * convert to new LIB_DEPENDS format * change <pre> & <post> includes to <options>
Diffstat (limited to 'mail/enma/Makefile')
-rw-r--r--mail/enma/Makefile33
1 files changed, 15 insertions, 18 deletions
diff --git a/mail/enma/Makefile b/mail/enma/Makefile
index c08668607c90..c7596d52a2e2 100644
--- a/mail/enma/Makefile
+++ b/mail/enma/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/ENMA/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Sender authentication milter supporting SPF and Sender ID
LICENSE= BSD
@@ -17,19 +17,18 @@ OPTIONS_DEFINE= LIBBIND
LIBBIND_DESC= Link against dns/libbind instead of dns/ldns
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --prefix=${PREFIX} --mandir=${PREFIX}/man \
- --with-ssl-incdir=${OPENSSLINC} --with-ssl-libdir=${OPENSSLLIB}
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --mandir=${PREFIX}/man \
+ --with-ssl-incdir=${OPENSSLINC} \
+ --with-ssl-libdir=${OPENSSLLIB}
USES= gmake perl5
USE_RC_SUBR= milter-enma
USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_PERL5= build
+LDFLAGS+= -lssl
MANLANG= "" ja_JP.UTF-8
-MAN1= enma.1
-MANCOMPRESSED= no
-PLIST_FILES= bin/sidfquery etc/enma.conf.sample lib/libsauth.a lib/libsauth.la \
- lib/libsauth.so lib/libsauth.so.0 libexec/enma
PORTDOCS= ChangeLog INSTALL LICENSE README
SUB_FILES= milter-enma
@@ -42,8 +41,7 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/postfix/smtpd:${PORTSDIR}/mail/postfix
. endif
.endif
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.include "${PORTSDIR}/mail/sendmail/bsd.milter.mk"
.if ${PORT_OPTIONS:MLIBBIND}
@@ -53,21 +51,20 @@ CONFIGURE_ARGS+= --with-resolver=libbind \
BUILD_DEPENDS+= ${LOCALBASE}/lib/libbind.a:${PORTSDIR}/dns/libbind
.else
CONFIGURE_ARGS+= --with-resolver=ldns
-LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
+LIB_DEPENDS+= libldns.so:${PORTSDIR}/dns/ldns
.endif
pre-configure:
$$(${CONF_SUB})
post-install:
- ${INSTALL_DATA} ${WRKSRC}/enma/etc/enma.conf.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/enma/etc/enma.conf.sample \
+ ${STAGEDIR}${PREFIX}/etc
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+. endfor
.endif
- @${ECHO_CMD} "@unexec ${RMDIR} %D/man/ja_JP.UTF-8/man1 2>/dev/null || true" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${RMDIR} %D/man/ja_JP.UTF-8 2>/dev/null || true" >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>