aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim-devel
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-12-20 23:29:51 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-12-20 23:29:51 +0800
commit9097a0430e4676635f287640afb2c655cab7c83e (patch)
tree4df6badf34fdd88a39bf22298e540aca1e8ad9ec /mail/exim-devel
parent63d91f696e26a938172866d63fc4edf74387a293 (diff)
downloadfreebsd-ports-gnome-9097a0430e4676635f287640afb2c655cab7c83e.tar.gz
freebsd-ports-gnome-9097a0430e4676635f287640afb2c655cab7c83e.tar.zst
freebsd-ports-gnome-9097a0430e4676635f287640afb2c655cab7c83e.zip
Add a patch from the author that fixes a string termination bug. The
bug was the cause of the 'unknown named list "+local_domains"' problem for which the port was marked BROKEN. I haven't bumped PORTREVISION because the port was marked BROKEN so soon after it was added.
Diffstat (limited to 'mail/exim-devel')
-rw-r--r--mail/exim-devel/Makefile2
-rw-r--r--mail/exim-devel/files/patch-src::readconf.c10
2 files changed, 10 insertions, 2 deletions
diff --git a/mail/exim-devel/Makefile b/mail/exim-devel/Makefile
index bc8450d63817..3c1c909cd7dc 100644
--- a/mail/exim-devel/Makefile
+++ b/mail/exim-devel/Makefile
@@ -15,8 +15,6 @@ DISTFILES= exim-3.951.tar.bz2 exim-texinfo-3.951.tar.bz2
MAINTAINER= sheldonh@FreeBSD.org
-BROKEN= 'Default configuration file gives unknown named list "+local_domains"'
-
NO_LATEST_LINK= yes
USE_BZIP2= yes
diff --git a/mail/exim-devel/files/patch-src::readconf.c b/mail/exim-devel/files/patch-src::readconf.c
new file mode 100644
index 000000000000..0f6839f91ec6
--- /dev/null
+++ b/mail/exim-devel/files/patch-src::readconf.c
@@ -0,0 +1,10 @@
+--- src/readconf.c.orig Fri Nov 23 17:31:21 2001
++++ src/readconf.c Thu Dec 20 17:24:58 2001
+@@ -1990,6 +1990,7 @@
+ while (isalnum(*s) || *s == '_') s++;
+ t = store_get(sizeof(tree_node) + s-ss);
+ Ustrncpy(t->name, ss, s-ss);
++t->name[s-ss] = 0;
+ while (isspace(*s)) s++;
+
+ if (!tree_insertnode(anchorp, t))
ebsd-ports-gnome/commit/x11-toolkits/gtkmm30?id=2de83baa2e903fd8a9eee5c1dbcf9f9fa0692d79'>Fix the build on amd64.marcus2007-01-15