aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2011-01-10 18:53:13 +0800
committerEygene Ryabinkin <rea@FreeBSD.org>2011-01-10 18:53:13 +0800
commit08a59968ed4abe89380110639f25529ac33595c9 (patch)
tree881ce2118bf6e10d9050f3f62582930a8a9e731d /mail/exim
parent0dcab095d2b091c47f4a9430aaa71a171a107161 (diff)
downloadfreebsd-ports-gnome-08a59968ed4abe89380110639f25529ac33595c9.tar.gz
freebsd-ports-gnome-08a59968ed4abe89380110639f25529ac33595c9.tar.zst
freebsd-ports-gnome-08a59968ed4abe89380110639f25529ac33595c9.zip
mail/exim: fix variable substitution
There was an extra '=' sign at the sed substitution pattern that affected users of make-only options TRUSTED_CONFIG_LIST and WHITELIST_D_MACROS: Exim binary won't build if any of these options is set. Spotted by: tdb Pointyhat to: rea Approved by: erwin (mentor)
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 95109ff76d38..da94ded30274 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -453,12 +453,12 @@ SEDLIST+= -e 's,^\# (HAVE_IPV6=),\1,'
SEDLIST+= -e 's,^\# (DISABLE_D_OPTION=),\1,'
.else
.if defined(WHITELIST_D_MACROS)
-SEDLIST+= -e 's,^\# (WHITELIST_D_MACROS=).*$$,\1=${WHITELIST_D_MACROS:S/,/\\,/g},'
+SEDLIST+= -e 's,^\# (WHITELIST_D_MACROS=).*$$,\1${WHITELIST_D_MACROS:S/,/\\,/g},'
.endif
.endif
.if defined(TRUSTED_CONFIG_LIST)
-SEDLIST+= -e 's,^\# (TRUSTED_CONFIG_LIST=).*$$,\1=${TRUSTED_CONFIG_LIST:S/,/\\,/g},'
+SEDLIST+= -e 's,^\# (TRUSTED_CONFIG_LIST=).*$$,\1${TRUSTED_CONFIG_LIST:S/,/\\,/g},'
.endif
DUMMY_LDFLAGS!= ${ECHO_CMD} ${LDFLAGS} | ${SED} -e 's|-Wl,-rpath|-Wl,-DUMMYrpath|g; s|-rpath|-Wl,-rpath|g; s|-DUMMYrpath|-rpath|g'