aboutsummaryrefslogtreecommitdiffstats
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-08 20:12:44 +0800
committerpav <pav@FreeBSD.org>2009-01-08 20:12:44 +0800
commitf249548ae945ede318999dfca84aca771c4068f2 (patch)
tree161e2fd7df7a74a8cf0675aef65b73b523639ddd /mail/fetchmail
parent5642a7d60b4987541b46cd8f560119b2d429d036 (diff)
downloadfreebsd-ports-gnome-f249548ae945ede318999dfca84aca771c4068f2.tar.gz
freebsd-ports-gnome-f249548ae945ede318999dfca84aca771c4068f2.tar.zst
freebsd-ports-gnome-f249548ae945ede318999dfca84aca771c4068f2.zip
- Update to 6.3.9
PR: ports/129755 Submitted by: Matthias Andree <matthias.andree@gmx.de> Approved by: maintainer timeout (barner; 20 days)
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile5
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmail/files/patch-CVE-2007-456511
-rw-r--r--mail/fetchmail/files/patch-CVE-2008-271152
-rw-r--r--mail/fetchmail/files/patch-Makefile.in25
-rw-r--r--mail/fetchmail/files/patch-fetchlimit-exitstatus18
-rw-r--r--mail/fetchmail/pkg-plist10
7 files changed, 33 insertions, 94 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 8904e3e00b94..87289f326a4e 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -10,8 +10,7 @@
# want fetchmailconf to work, define WITH_X11
PORTNAME= fetchmail
-PORTVERSION= 6.3.8
-PORTREVISION= 7
+PORTVERSION= 6.3.9
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
${MASTER_SITE_SUNSITE:S/$/:sunsite/}\
@@ -35,7 +34,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
- --with-hesiod=no --enable-fallback=no
+ --with-hesiod=no --enable-fallback=no PYTHON=:
# bsd.openssl.mk will add the LDFLAGS to CONFIGURE_ENV:
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index 18607870ac57..f11be466a488 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-MD5 (fetchmail-6.3.8.tar.bz2) = 66b97500b0a1e3c0916b3b5314f597f5
-SHA256 (fetchmail-6.3.8.tar.bz2) = 5612f9af367f641e0efd084f44fcf1889669e711dbd8c60f6b7953e494d1b09b
-SIZE (fetchmail-6.3.8.tar.bz2) = 1323515
+MD5 (fetchmail-6.3.9.tar.bz2) = 72c20ad2b9629f1a109668b05a84d823
+SHA256 (fetchmail-6.3.9.tar.bz2) = 3dfd3b04aa552331f91f96bdf5f5afe489c31a600ae7973f5814bde5555813dc
+SIZE (fetchmail-6.3.9.tar.bz2) = 1538134
diff --git a/mail/fetchmail/files/patch-CVE-2007-4565 b/mail/fetchmail/files/patch-CVE-2007-4565
deleted file mode 100644
index 77783efde9af..000000000000
--- a/mail/fetchmail/files/patch-CVE-2007-4565
+++ /dev/null
@@ -1,11 +0,0 @@
---- sink.c (revision 5118)
-+++ sink.c (revision 5119)
-@@ -262,7 +262,7 @@
- const char *md1 = "MAILER-DAEMON", *md2 = "MAILER-DAEMON@";
-
- /* don't bounce in reply to undeliverable bounces */
-- if (!msg->return_path[0] ||
-+ if (!msg || !msg->return_path[0] ||
- strcmp(msg->return_path, "<>") == 0 ||
- strcasecmp(msg->return_path, md1) == 0 ||
- strncasecmp(msg->return_path, md2, strlen(md2)) == 0)
diff --git a/mail/fetchmail/files/patch-CVE-2008-2711 b/mail/fetchmail/files/patch-CVE-2008-2711
deleted file mode 100644
index adac89b03670..000000000000
--- a/mail/fetchmail/files/patch-CVE-2008-2711
+++ /dev/null
@@ -1,52 +0,0 @@
---- report.c.orig 2008-07-01 18:15:58.000000000 +0200
-+++ report.c 2008-07-01 18:18:53.000000000 +0200
-@@ -238,11 +238,17 @@
- rep_ensuresize();
-
- #if defined(VA_START)
-- VA_START (args, message);
- for ( ; ; )
- {
-+ /*
-+ * args has to be initialized before every call of vsnprintf(),
-+ * because vsnprintf() invokes va_arg macro and thus args is
-+ * undefined after the call.
-+ */
-+ VA_START(args, message);
- n = vsnprintf (partial_message + partial_message_size_used, partial_message_size - partial_message_size_used,
- message, args);
-+ va_end (args);
-
- if (n >= 0
- && (unsigned)n < partial_message_size - partial_message_size_used)
-@@ -254,7 +260,6 @@
- partial_message_size += 2048;
- partial_message = REALLOC (partial_message, partial_message_size);
- }
-- va_end (args);
- #else
- for ( ; ; )
- {
-@@ -304,12 +309,13 @@
- rep_ensuresize();
-
- #if defined(VA_START)
-- VA_START (args, message);
- for ( ; ; )
- {
-+ VA_START(args, message);
- n = vsnprintf (partial_message + partial_message_size_used,
- partial_message_size - partial_message_size_used,
- message, args);
-+ va_end(args);
-
- /* old glibc versions return -1 for truncation */
- if (n >= 0
-@@ -322,7 +328,6 @@
- partial_message_size += 2048;
- partial_message = REALLOC (partial_message, partial_message_size);
- }
-- va_end (args);
- #else
- for ( ; ; )
- {
diff --git a/mail/fetchmail/files/patch-Makefile.in b/mail/fetchmail/files/patch-Makefile.in
index 45ac0da45747..18481ce617d6 100644
--- a/mail/fetchmail/files/patch-Makefile.in
+++ b/mail/fetchmail/files/patch-Makefile.in
@@ -9,28 +9,3 @@
INSTALL_HEADER = $(INSTALL_DATA)
transform = $(program_transform_name)
NORMAL_INSTALL = :
-@@ -864,24 +864,6 @@
- rm -f y.tab.c
- uninstall-info-am:
- install-pythonPYTHON: $(python_PYTHON)
-- @$(NORMAL_INSTALL)
-- test -z "$(pythondir)" || $(mkdir_p) "$(DESTDIR)$(pythondir)"
-- @list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
-- if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
-- if test -f $$b$$p; then \
-- f=$(am__strip_dir) \
-- dlist="$$dlist $$f"; \
-- echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
-- $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
-- else :; fi; \
-- done; \
-- if test -n "$$dlist"; then \
-- if test -z "$(DESTDIR)"; then \
-- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
-- else \
-- PYTHON=$(PYTHON) $(py_compile) --destdir "$(DESTDIR)" --basedir "$(pythondir)" $$dlist; \
-- fi; \
-- else :; fi
-
- uninstall-pythonPYTHON:
- @$(NORMAL_UNINSTALL)
diff --git a/mail/fetchmail/files/patch-fetchlimit-exitstatus b/mail/fetchmail/files/patch-fetchlimit-exitstatus
new file mode 100644
index 000000000000..dd79d235ffe5
--- /dev/null
+++ b/mail/fetchmail/files/patch-fetchlimit-exitstatus
@@ -0,0 +1,18 @@
+Index: driver.c
+===================================================================
+--- driver.c (Revision 5254)
++++ driver.c (Revision 5255)
+@@ -1435,9 +1435,11 @@
+ /* end-of-mailbox processing before we repoll or switch to another one */
+ if (ctl->server.base_protocol->end_mailbox_poll)
+ {
+- err = (ctl->server.base_protocol->end_mailbox_poll)(mailserver_socket, ctl);
+- if (err)
++ tmperr = (ctl->server.base_protocol->end_mailbox_poll)(mailserver_socket, ctl);
++ if (tmperr) {
++ err = tmperr;
+ goto cleanUp;
++ }
+ }
+ /* Return now if we have reached the fetchlimit */
+ if (maxfetch && maxfetch <= fetches)
diff --git a/mail/fetchmail/pkg-plist b/mail/fetchmail/pkg-plist
index 7a9fcb0dfa8e..bdce315d512f 100644
--- a/mail/fetchmail/pkg-plist
+++ b/mail/fetchmail/pkg-plist
@@ -16,15 +16,25 @@ libexec/fetchmailconf.py
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%NLS%%share/locale/ca/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/cs/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/da/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/de/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/el/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/es/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/fr/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/id/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/ja/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/pl/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/ru/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/sq/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/fetchmail.mo
%%NLS%%share/locale/vi/LC_MESSAGES/fetchmail.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/fetchmail.mo
@unexec if cmp -s %D/etc/fetchmailrc.sample %D/etc/fetchmailrc; then rm -f %D/etc/fetchmailrc; fi
etc/fetchmailrc.sample
@exec if [ ! -f %D/etc/fetchmailrc ] ; then cp -p %D/%F %B/fetchmailrc; fi