aboutsummaryrefslogtreecommitdiffstats
path: root/mail/greylite
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-02 07:18:19 +0800
committerbapt <bapt@FreeBSD.org>2013-06-02 07:18:19 +0800
commitbb2507ee9768f7dbf5718c5e592ffd6fc3c1d831 (patch)
treefc1da988ed9c9cba707cf220721bac89300d0c78 /mail/greylite
parentc58a15df775d75a040a08e6253d56a8e8b74044a (diff)
downloadfreebsd-ports-gnome-bb2507ee9768f7dbf5718c5e592ffd6fc3c1d831.tar.gz
freebsd-ports-gnome-bb2507ee9768f7dbf5718c5e592ffd6fc3c1d831.tar.zst
freebsd-ports-gnome-bb2507ee9768f7dbf5718c5e592ffd6fc3c1d831.zip
Convert to new options framework
Diffstat (limited to 'mail/greylite')
-rw-r--r--mail/greylite/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
index c2281a453623..85eb8906bb3f 100644
--- a/mail/greylite/Makefile
+++ b/mail/greylite/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: greylite
-# Date created: 2007-12-11
-# Whom: Mij <mij@bitchx.it>
-#
+# Created by: Mij <mij@bitchx.it>
# $FreeBSD$
-#
PORTNAME= greylite
PORTVERSION= 2.3
@@ -25,18 +21,20 @@ PLIST_FILES= bin/greylite \
MAN8= greylite.8
MANCOMPRESSED= yes
-OPTIONS= GEOIP "Support for GeoIP in suspicion rules" On \
- DNSBLENV "Module for interfacing with DNS blacklists" On \
- UCSPI2SOCKET "Module for using greylite as SMTP proxy" On
+OPTIONS_DEFINE= GEOIP DNSBLENV UCSPI2SOCKET
+OPTIONS_DEFAULT= GEOIP DNSBLENV UCSPI2SOCKET
+GEOIP_DESC= Support for GeoIP in suspicion rules
+DNSBLENV_DESC= Module for interfacing with DNS blacklists
+UCSPI2SOCKET_DESC= Module for using greylite as SMTP proxy
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_GEOIP)
+.if ${PORT_OPTIONS:MGEOIP}
LIB_DEPENDS+= GeoIP:${PORTSDIR}/net/GeoIP
MAKE_ARGS+= WITH_GEOIP=yep
.endif
-.if !defined(WITHOUT_DNSBLENV)
+.if ${PORT_OPTIONS:MDNSBLENV}
LIB_DEPENDS+= cares:${PORTSDIR}/dns/c-ares
MAKE_ARGS+= WITH_DNSBLENV=yep
PLIST_SUB+= DNSBLENV=""
@@ -44,7 +42,7 @@ PLIST_SUB+= DNSBLENV=""
PLIST_SUB+= DNSBLENV="@comment "
.endif
-.if !defined(WITHOUT_UCSPI2SOCKET)
+.if ${PORT_OPTIONS:MUCSPI2SOCKET}
MAKE_ARGS+= WITH_UCSPI2SOCKET=yep
PLIST_SUB+= UCSPI2SOCKET=""
.else