aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde-turba/pkg-deinstall
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2003-01-30 17:59:58 +0800
committerdirk <dirk@FreeBSD.org>2003-01-30 17:59:58 +0800
commit0fde8562ff7b6dcdf1b861872ea4ac09a1bf2ddd (patch)
tree1f21f1b91a4be11e4c6801b125bc83c9e6cb790b /mail/horde-turba/pkg-deinstall
parent2024599b17782ae972fc601af48270ce99c5e8aa (diff)
downloadfreebsd-ports-gnome-0fde8562ff7b6dcdf1b861872ea4ac09a1bf2ddd.tar.gz
freebsd-ports-gnome-0fde8562ff7b6dcdf1b861872ea4ac09a1bf2ddd.tar.zst
freebsd-ports-gnome-0fde8562ff7b6dcdf1b861872ea4ac09a1bf2ddd.zip
- backup config files + DB suport moved to Horde
- fix ftp sites PR: ports/47418 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'mail/horde-turba/pkg-deinstall')
-rw-r--r--mail/horde-turba/pkg-deinstall27
1 files changed, 27 insertions, 0 deletions
diff --git a/mail/horde-turba/pkg-deinstall b/mail/horde-turba/pkg-deinstall
new file mode 100644
index 000000000000..b0a141eef091
--- /dev/null
+++ b/mail/horde-turba/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Turba config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls ${PKG_PREFIX}/www/horde/turba/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi