aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde-vacation
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-03-13 02:08:49 +0800
committersat <sat@FreeBSD.org>2007-03-13 02:08:49 +0800
commit2d91fbe3a3d02172dec90229f24ab0a4e70b5328 (patch)
treecf5b15ed25e4154334e43f2440dbd30dbfcb09ee /mail/horde-vacation
parent98acc4f997ac6f6d7ce6fc9ec9c9cb4dea53e7cb (diff)
downloadfreebsd-ports-gnome-2d91fbe3a3d02172dec90229f24ab0a4e70b5328.tar.gz
freebsd-ports-gnome-2d91fbe3a3d02172dec90229f24ab0a4e70b5328.tar.zst
freebsd-ports-gnome-2d91fbe3a3d02172dec90229f24ab0a4e70b5328.zip
Add port mail/horde-vacation:
Vacation is a Horde module for managing user e-mail "vacation notices" or "auto-responders." It works via a local vacation program and the .forward style forwarding mechanism supported by several popular mailers. Right now, Vacation provides fairly complete support for managing .forward style vacation notices on Sendmail or Courier mail based systems via an FTP transport. It also has some support for LDAP, Qmail, and SQL servers. WWW: http://www.horde.org/vacation/ PR: ports/110123 Submitted by: Beech Rintoul <beech@alaskaparadise.com>
Diffstat (limited to 'mail/horde-vacation')
-rw-r--r--mail/horde-vacation/Makefile101
-rw-r--r--mail/horde-vacation/distinfo3
-rw-r--r--mail/horde-vacation/pkg-descr9
-rw-r--r--mail/horde-vacation/pkg-plist128
4 files changed, 241 insertions, 0 deletions
diff --git a/mail/horde-vacation/Makefile b/mail/horde-vacation/Makefile
new file mode 100644
index 000000000000..fbe69a1c2c16
--- /dev/null
+++ b/mail/horde-vacation/Makefile
@@ -0,0 +1,101 @@
+# Ports collection makefile for: vacation3
+# Date created: Thu Mar 08, 2007
+# Whom: Beech Rintoul <beech@alaskaparadise.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vacation
+PORTVERSION= 3.0
+DISTVERSIONPREFIX= h3-
+CATEGORIES= mail www
+MASTER_SITES= HORDE
+PKGNAMEPREFIX= horde-
+
+MAINTAINER= beech@alaskaparadise.com
+COMMENT= E-mail auto-responder
+
+#-----------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_LDAP if you do not need OpenLDAP;
+#
+# - WITHOUT_FTP disable FTP support;
+#-----------------------------------------------------------------------
+
+RUN_DEPENDS+= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
+
+. if !defined(WITHOUT_LDAP)
+USE_PHP+= ldap
+. endif
+
+.if !defined(WITHOUT_FTP)
+USE_PHP+= ftp
+.endif
+
+RUN_DEPENDS+= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde-base
+
+NO_BUILD= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
+USE_GETTEXT= yes
+REINPLACE_ARGS= -i ""
+
+PORTDOCS= CHANGES CREDITS INSTALL RELEASE_NOTES TODO
+CONFFILE= conf.xml .htaccess
+SUB_DIRS= config files lib locale po scripts templates themes
+
+LHORDEDIR?= www/horde
+LVACDIR= ${LHORDEDIR}/vacation
+PEARDIR?= ${LOCALBASE}/share/pear
+
+PLIST_SUB= VACDIR=${LVACDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
+SUB_LIST= VACDIR=${VACDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
+
+VACDIR= ${PREFIX}/${LVACDIR}
+CONFDIR= ${VACDIR}/config
+
+HOSTNAME?= `/bin/hostname`
+SERVOS?= ${OPSYS}-${OSREL}
+
+PORTREV_H?= ${LOCALBASE}/include/c-client/portrevision.h
+
+.include <bsd.port.pre.mk>
+
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes/
+.else
+HORDE_INC= ${LOCALBASE}/etc/horde/
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}/README ${WRKSRC}/docs/
+
+pre-configure:
+ @${REINPLACE_CMD} -e "s:/usr/local:${LOCALBASE}:" ${WRKSRC}/config/conf.xml
+ @${SED} -e "s:/home/httpd/html/horde/vacation:${VACDIR}:" \
+ ${FILESDIR}/httpd.conf.vacation > ${WRKDIR}/httpd-vacation.conf
+
+do-install:
+ @${INSTALL} -d ${VACDIR}/
+ @${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${VACDIR}/
+ @${CP} -p ${WRKSRC}/*.php ${VACDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}/
+ @${INSTALL_DATA} ${WRKDIR}/httpd-vacation.conf ${HORDE_INC}/
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${VACDIR}/
+ @${CHMOD} -R o-rwx ${CONFDIR}/
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${DOCSDIR}/
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>
diff --git a/mail/horde-vacation/distinfo b/mail/horde-vacation/distinfo
new file mode 100644
index 000000000000..c88aefbfc60f
--- /dev/null
+++ b/mail/horde-vacation/distinfo
@@ -0,0 +1,3 @@
+MD5 (vacation-h3-3.0.tar.gz) = aebac7f1f1a1bdf8d7f9a7ed8aecee8e
+SHA256 (vacation-h3-3.0.tar.gz) = 1c41e20015242eadc30d9da3ea15748e511e14bea671b62fd57c5daf69d4e502
+SIZE (vacation-h3-3.0.tar.gz) = 836530
diff --git a/mail/horde-vacation/pkg-descr b/mail/horde-vacation/pkg-descr
new file mode 100644
index 000000000000..91691808caec
--- /dev/null
+++ b/mail/horde-vacation/pkg-descr
@@ -0,0 +1,9 @@
+Vacation is a Horde module for managing user e-mail "vacation notices" or
+"auto-responders." It works via a local vacation program and the .forward style
+forwarding mechanism supported by several popular mailers.
+
+Right now, Vacation provides fairly complete support for managing .forward style
+vacation notices on Sendmail or Courier mail based systems via an FTP transport.
+It also has some support for LDAP, Qmail, and SQL servers.
+
+WWW: http://www.horde.org/vacation/
diff --git a/mail/horde-vacation/pkg-plist b/mail/horde-vacation/pkg-plist
new file mode 100644
index 000000000000..03e2d6cc44c5
--- /dev/null
+++ b/mail/horde-vacation/pkg-plist
@@ -0,0 +1,128 @@
+%%VACDIR%%/config/.htaccess
+%%VACDIR%%/config/conf.xml
+%%VACDIR%%/files/empty.btree.bin
+%%VACDIR%%/files/empty.empty.bin
+%%VACDIR%%/files/empty.gdbm.bin
+%%VACDIR%%/files/empty.hash.bin
+%%VACDIR%%/files/empty.hash3.bin
+%%VACDIR%%/index.php
+%%VACDIR%%/lib/AliasDriver/ftp.php
+%%VACDIR%%/lib/AliasDriver/none.php
+%%VACDIR%%/lib/Block/summary.php
+%%VACDIR%%/lib/AliasDriver.php
+%%VACDIR%%/lib/base.php
+%%VACDIR%%/lib/Driver.php
+%%VACDIR%%/lib/Driver/forwards.php
+%%VACDIR%%/lib/Driver/ldap.php
+%%VACDIR%%/lib/Driver/qmail.php
+%%VACDIR%%/lib/Driver/sql.php
+%%VACDIR%%/lib/.htaccess
+%%VACDIR%%/lib/version.php
+%%VACDIR%%/locale/bg_BG/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/cs_CZ/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/da_DK/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/de_DE/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/el_GR/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/en_US/help.xml
+%%VACDIR%%/locale/es_ES/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/es_ES/help.xml
+%%VACDIR%%/locale/fa_IR/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/fa_IR/help.xml
+%%VACDIR%%/locale/fi_FI/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/fi_FI/help.xml
+%%VACDIR%%/locale/fr_FR/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/gl_ES/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/hu_HU/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/it_IT/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/nl_NL/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/nl_NL/help.xml
+%%VACDIR%%/locale/nn_NO/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/pl_PL/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/pt_BR/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/ro_RO/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/sv_SE/LC_MESSAGES/vacation.mo
+%%VACDIR%%/locale/zh_TW/LC_MESSAGES/vacation.mo
+%%VACDIR%%/main.php
+%%VACDIR%%/po/README
+%%VACDIR%%/po/.htaccess
+%%VACDIR%%/po/bg_BG.po
+%%VACDIR%%/po/cs_CZ.po
+%%VACDIR%%/po/da_DK.po
+%%VACDIR%%/po/de_DE.po
+%%VACDIR%%/po/el_GR.po
+%%VACDIR%%/po/es_ES.po
+%%VACDIR%%/po/fa_IR.po
+%%VACDIR%%/po/fi_FI.po
+%%VACDIR%%/po/fr_FR.po
+%%VACDIR%%/po/gl_ES.po
+%%VACDIR%%/po/hu_HU.po
+%%VACDIR%%/po/it_IT.po
+%%VACDIR%%/po/nl_NL.po
+%%VACDIR%%/po/nn_NO.po
+%%VACDIR%%/po/pl_PL.po
+%%VACDIR%%/po/pt_BR.po
+%%VACDIR%%/po/ro_RO.po
+%%VACDIR%%/po/sv_SE.po
+%%VACDIR%%/po/vacation.pot
+%%VACDIR%%/po/zh_TW.po
+%%VACDIR%%/scripts/.htaccess
+%%VACDIR%%/scripts/create-db-files.pl
+%%VACDIR%%/templates/common-header.inc
+%%VACDIR%%/templates/.htaccess
+%%VACDIR%%/templates/main/main.inc
+%%VACDIR%%/themes/graphics/favicon.ico
+%%VACDIR%%/themes/graphics/vacation.png
+%%HORDE_INC%%httpd-vacation.conf
+@dirrm %%VACDIR%%/themes/graphics
+@dirrm %%VACDIR%%/themes
+@dirrm %%VACDIR%%/templates/main
+@dirrm %%VACDIR%%/templates
+@dirrm %%VACDIR%%/scripts
+@dirrm %%VACDIR%%/po
+@dirrm %%VACDIR%%/locale/zh_TW/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/zh_TW
+@dirrm %%VACDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/sv_SE
+@dirrm %%VACDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/ro_RO
+@dirrm %%VACDIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/pt_BR
+@dirrm %%VACDIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/pl_PL
+@dirrm %%VACDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/nn_NO
+@dirrm %%VACDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/nl_NL
+@dirrm %%VACDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/it_IT
+@dirrm %%VACDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/hu_HU
+@dirrm %%VACDIR%%/locale/gl_ES/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/gl_ES
+@dirrm %%VACDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/fr_FR
+@dirrm %%VACDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/fi_FI
+@dirrm %%VACDIR%%/locale/fa_IR/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/fa_IR
+@dirrm %%VACDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/es_ES
+@dirrm %%VACDIR%%/locale/en_US
+@dirrm %%VACDIR%%/locale/el_GR/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/el_GR
+@dirrm %%VACDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/de_DE
+@dirrm %%VACDIR%%/locale/da_DK/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/da_DK
+@dirrm %%VACDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/cs_CZ
+@dirrm %%VACDIR%%/locale/bg_BG/LC_MESSAGES
+@dirrm %%VACDIR%%/locale/bg_BG
+@dirrm %%VACDIR%%/locale
+@dirrm %%VACDIR%%/lib/Driver
+@dirrm %%VACDIR%%/lib/Block
+@dirrm %%VACDIR%%/lib/AliasDriver
+@dirrm %%VACDIR%%/lib
+@dirrm %%VACDIR%%/files
+@dirrmtry %%VACDIR%%/config
+@dirrmtry %%VACDIR%%