aboutsummaryrefslogtreecommitdiffstats
path: root/mail/imp
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-01-06 08:38:13 +0800
committerthierry <thierry@FreeBSD.org>2006-01-06 08:38:13 +0800
commit922106489a63564790d516923e03c8fa28346fa9 (patch)
tree20dad146d367f92c711d016c12e8e3340824db6b /mail/imp
parent65a0f264588bfc3e5c26e6b14ba972c45fca49a3 (diff)
downloadfreebsd-ports-gnome-922106489a63564790d516923e03c8fa28346fa9.tar.gz
freebsd-ports-gnome-922106489a63564790d516923e03c8fa28346fa9.tar.zst
freebsd-ports-gnome-922106489a63564790d516923e03c8fa28346fa9.zip
- Replace WITH_APACHE2 by USE_APACHE, rename httpd.conf.xxx to
httpd-xxx.conf and fix configuration if APACHE_VERSION > 20. - Don't use the MCAL back-end by default for Kronolith, it is deprecated. - Deinstall bug reported by John Nielsen <john (at) jnielsen.net>: respect LHORDEDIR. - Fix horde-passwd installation / deinstallation. - Don't bump PORTREVISION, because running installations are not concerned.
Diffstat (limited to 'mail/imp')
-rw-r--r--mail/imp/Makefile21
-rw-r--r--mail/imp/distinfo1
-rw-r--r--mail/imp/files/pkg-deinstall.in (renamed from mail/imp/pkg-deinstall)2
-rw-r--r--mail/imp/pkg-plist2
4 files changed, 16 insertions, 10 deletions
diff --git a/mail/imp/Makefile b/mail/imp/Makefile
index 3e5ccc623cf5..54440c11568a 100644
--- a/mail/imp/Makefile
+++ b/mail/imp/Makefile
@@ -104,6 +104,7 @@ RUN_DEPENDS+= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
.endif
NO_BUILD= yes
+USE_APACHE= 1.3+ # needed to test APACHE_VERSION
USE_REINPLACE= yes
REINPLACE_ARGS= -i.beforeIMP
@@ -117,17 +118,15 @@ LHORDEDIR?= www/horde
LIMPDIR= ${LHORDEDIR}/imp
PEARDIR?= ${LOCALBASE}/share/pear
-PLIST_SUB= IMPDIR=${LIMPDIR}
-SUB_LIST= IMPDIR=${IMPDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
-
+PLIST_SUB= IMPDIR=${LIMPDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_FILES= pkg-message
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-message pkg-deinstall
+SUB_LIST= IMPDIR=${IMPDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
IMPDIR= ${PREFIX}/${LIMPDIR}
CONFDIR= ${IMPDIR}/config
-HORDE_INC= ${LOCALBASE}/etc/horde
-
HOSTNAME?= `/bin/hostname`
SERVOS?= ${OPSYS}-${OSREL}
@@ -158,6 +157,12 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/imapd:${PORTSDIR}/mail/imap-uw
. endif
.endif
+.if ${APACHE_VERSION} >= 20
+HORDE_INC= ${LOCALBASE}/etc/apache${APACHE_VERSION:S/20/2/}/Includes
+.else
+HORDE_INC= ${LOCALBASE}/etc/horde
+.endif
+
pre-everything::
.if !defined(WITHOUT_IMAPSERVER)
@${ECHO_MSG} ""
@@ -200,7 +205,7 @@ pre-configure:
. endif
.endif
@${SED} -e "s:/home/httpd/html/horde/imp:${IMPDIR}:" \
- ${FILESDIR}/httpd.conf.imp > ${WRKDIR}/httpd.conf.imp
+ ${FILESDIR}/httpd.conf.imp > ${WRKDIR}/httpd-imp.conf
.for fc in ${PATCH2RM}
@${RM} ${WRKSRC}/config/${fc}
.endfor
@@ -228,7 +233,7 @@ do-install:
fi
.endfor
@${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}
- @${INSTALL_DATA} ${WRKDIR}/httpd.conf.imp ${HORDE_INC}
+ @${INSTALL_DATA} ${WRKDIR}/httpd-imp.conf ${HORDE_INC}
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${IMPDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
.if !defined(NOPORTDOCS)
diff --git a/mail/imp/distinfo b/mail/imp/distinfo
index 06a2bb31b08b..22d57099697c 100644
--- a/mail/imp/distinfo
+++ b/mail/imp/distinfo
@@ -1,2 +1,3 @@
MD5 (imp-h3-4.0.4.tar.gz) = 437767b420c6280e680a42c8e34182d1
+SHA256 (imp-h3-4.0.4.tar.gz) = aa814f8f2bee0912a50df6220c77a60b43d83a52b0bc49dffbd30b63845c08d1
SIZE (imp-h3-4.0.4.tar.gz) = 3349908
diff --git a/mail/imp/pkg-deinstall b/mail/imp/files/pkg-deinstall.in
index cd0aa1e6c6c5..13bb805c47d5 100644
--- a/mail/imp/pkg-deinstall
+++ b/mail/imp/files/pkg-deinstall.in
@@ -9,7 +9,7 @@ if [ x$2 != xDEINSTALL ]; then
fi
if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls ${PKG_PREFIX}/www/horde/imp/config/*php ${PKG_PREFIX}/www/horde/imp/config/*txt`; do
+ for cf in `ls %%IMPDIR%%/config/*php %%IMPDIR%%/config/*txt`; do
diff -bBqw $cf $cf.dist >/dev/null 2>&1
case $? in
0) # original config file, will be deleted by pkg-plist
diff --git a/mail/imp/pkg-plist b/mail/imp/pkg-plist
index cc4300f87ce6..4aed11a161f8 100644
--- a/mail/imp/pkg-plist
+++ b/mail/imp/pkg-plist
@@ -361,7 +361,7 @@
%%IMPDIR%%/thread.php
%%IMPDIR%%/view.php
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-etc/horde/httpd.conf.imp
+%%HORDE_INC%%/httpd-imp.conf
@dirrm %%IMPDIR%%/themes/sun
@dirrm %%IMPDIR%%/themes/simplex
@dirrm %%IMPDIR%%/themes/postnuke