aboutsummaryrefslogtreecommitdiffstats
path: root/mail/jwsmtp
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-07-12 04:14:30 +0800
committerpi <pi@FreeBSD.org>2016-07-12 04:14:30 +0800
commit6e348710b5066afce67ea245ec8bb3f6ff4b76bc (patch)
treefed9e4240bae840165133d760acbbfdca6052625 /mail/jwsmtp
parentf8953e6e88350e39882192b0dd578305e6de6033 (diff)
downloadfreebsd-ports-gnome-6e348710b5066afce67ea245ec8bb3f6ff4b76bc.tar.gz
freebsd-ports-gnome-6e348710b5066afce67ea245ec8bb3f6ff4b76bc.tar.zst
freebsd-ports-gnome-6e348710b5066afce67ea245ec8bb3f6ff4b76bc.zip
New port: mail/jwsmtp
jwSMTP is a GPL-licensed C++ library to facilitate sending email programmatically. All you need to worry about is who the mail is from, who to send it to and the message itself, no network coding necessary. It is able to send mail in html or plain format. jwSMTP can send attachments, send to multiple recipients including Cc/Bcc recipients. LOGIN and PLAIN SMTP authentication. Do an MX lookup or send direct via an smtp server. Supported platforms are BSD, Linux and Windows. WWW: https://talk.mumbleface.net/jwsmtp/ PR: 210765 Submitted by: Mohammad S. Babaei <info@babaei.net>
Diffstat (limited to 'mail/jwsmtp')
-rw-r--r--mail/jwsmtp/Makefile41
-rw-r--r--mail/jwsmtp/distinfo2
-rw-r--r--mail/jwsmtp/pkg-descr10
-rw-r--r--mail/jwsmtp/pkg-plist21
4 files changed, 74 insertions, 0 deletions
diff --git a/mail/jwsmtp/Makefile b/mail/jwsmtp/Makefile
new file mode 100644
index 000000000000..405a68b99e16
--- /dev/null
+++ b/mail/jwsmtp/Makefile
@@ -0,0 +1,41 @@
+# Created by: Mohammad S. Babaei <info@babaei.net>
+# $FreeBSD$
+
+PORTNAME= jwsmtp
+PORTVERSION= 1.32.15
+CATEGORIES= mail
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/jwsmtp%20version%201.32.15%20bugfix/
+
+MAINTAINER= info@babaei.net
+COMMENT= C++ library for sending email
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+NO_OPTIONS_SORT= yes
+OPTIONS_DEFINE= DOCS MANPAGES
+OPTIONS_DEFAULT= DOCS MANPAGES
+
+DOCS_DESC= Install documentation
+MANPAGES_DESC= Install manpages
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= libtool pathfix
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_SUB+= PORTDOCS=""
+.else
+PLIST_SUB+= PORTDOCS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MMANPAGES}
+PLIST_SUB+= MANPAGES=""
+.else
+PLIST_SUB+= MANPAGES="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/jwsmtp/distinfo b/mail/jwsmtp/distinfo
new file mode 100644
index 000000000000..b8957d27ba41
--- /dev/null
+++ b/mail/jwsmtp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jwsmtp-1.32.15.tar.gz) = 46227cd677f64850de0b23f6f6764576ddacb637011f34d16386fb31cdd2d722
+SIZE (jwsmtp-1.32.15.tar.gz) = 458872
diff --git a/mail/jwsmtp/pkg-descr b/mail/jwsmtp/pkg-descr
new file mode 100644
index 000000000000..6227b40d2e3e
--- /dev/null
+++ b/mail/jwsmtp/pkg-descr
@@ -0,0 +1,10 @@
+jwSMTP is a GPL-licensed C++ library to facilitate sending email
+programmatically. All you need to worry about is who the mail is from, who to
+send it to and the message itself, no network coding necessary. It is able to
+send mail in html or plain format. jwSMTP can send attachments, send to
+multiple recipients including Cc/Bcc recipients. LOGIN and PLAIN SMTP
+authentication. Do an MX lookup or send direct via an smtp server.
+
+Supported platforms are BSD, Linux and Windows.
+
+WWW: https://talk.mumbleface.net/jwsmtp/
diff --git a/mail/jwsmtp/pkg-plist b/mail/jwsmtp/pkg-plist
new file mode 100644
index 000000000000..ad512adc4780
--- /dev/null
+++ b/mail/jwsmtp/pkg-plist
@@ -0,0 +1,21 @@
+include/jwsmtp-1.32/jwsmtp/base64.h
+include/jwsmtp-1.32/jwsmtp/compat.h
+include/jwsmtp-1.32/jwsmtp/jwsmtp.h
+include/jwsmtp-1.32/jwsmtp/mailer.h
+lib/libjwsmtp-1.32.so
+lib/libjwsmtp.a
+lib/libjwsmtp.so
+libdata/pkgconfig/jwsmtp-1.32.pc
+%%MANPAGES%%man/man3/jwsmtp.3.gz
+%%PORTDOCS%%%%DOCSDIR%%-1.32/Copying
+%%PORTDOCS%%%%DOCSDIR%%-1.32/basic_code.html
+%%PORTDOCS%%%%DOCSDIR%%-1.32/functions.html
+%%PORTDOCS%%%%DOCSDIR%%-1.32/index.html
+%%PORTDOCS%%%%DOCSDIR%%-1.32/install.html
+%%PORTDOCS%%%%DOCSDIR%%-1.32/lib-set.jpg
+%%PORTDOCS%%%%DOCSDIR%%-1.32/mailer_class.html
+%%PORTDOCS%%%%DOCSDIR%%-1.32/main.css
+%%PORTDOCS%%%%DOCSDIR%%-1.32/t-o-i.jpg
+%%PORTDOCS%%%%DOCSDIR%%-1.32/t-o-l.jpg
+%%PORTDOCS%%%%DOCSDIR%%-1.32/usage.html
+%%PORTDOCS%%%%DOCSDIR%%-1.32/win.html