aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libetpan
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-06-08 06:44:21 +0800
committerpawel <pawel@FreeBSD.org>2012-06-08 06:44:21 +0800
commit2a1ebc56ba5020d2bf92961dbe81972f5a54841d (patch)
tree973987c82bdc40f9b4f7cd63831224e568aba682 /mail/libetpan
parent10b52a170f1d404abc5699061d2a3cf931eeb1e5 (diff)
downloadfreebsd-ports-gnome-2a1ebc56ba5020d2bf92961dbe81972f5a54841d.tar.gz
freebsd-ports-gnome-2a1ebc56ba5020d2bf92961dbe81972f5a54841d.tar.zst
freebsd-ports-gnome-2a1ebc56ba5020d2bf92961dbe81972f5a54841d.zip
Convert my ports to optionsNG
Diffstat (limited to 'mail/libetpan')
-rw-r--r--mail/libetpan/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index 8eb0fd201b83..ab9f9c6e5a91 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -29,21 +29,29 @@ MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-OPTIONS= GNUTLS "Enable gnuTLS support" off \
- IPV6 "Enable ipv6 support." on
+OPTIONS_DEFINE= IPV6
+OPTIONS_SINGLE= CRYPTO
+OPTIONS_SINGLE_CRYPTO= GNUTLS OPENSSL
+GNUTLS_DESC= Enable GNUTLS support
+OPENSSL_DESC= Enable OpenSSL support
+OPTIONS_DEFAULT= IPV6 OPENSSL
-.if defined(WITH_GNUTLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --without-openssl --with-gnutls
-.else
+.endif
+
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+= --without-gnutls
.endif
-.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --disable-ipv6
-.else
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
.endif
AUTOTOOLSFILES= aclocal.m4