aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libmapi/Makefile
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2012-06-13 02:49:15 +0800
committerkwm <kwm@FreeBSD.org>2012-06-13 02:49:15 +0800
commit9864bba3bf996703e83a7386612f413f7a242f5d (patch)
tree6d34a5f2e120069b93dd1d92a56f8ccb5004eb83 /mail/libmapi/Makefile
parent7ea5fb3e6ed6db833702e68b1535dbbc9b3d67e0 (diff)
downloadfreebsd-ports-gnome-9864bba3bf996703e83a7386612f413f7a242f5d.tar.gz
freebsd-ports-gnome-9864bba3bf996703e83a7386612f413f7a242f5d.tar.zst
freebsd-ports-gnome-9864bba3bf996703e83a7386612f413f7a242f5d.zip
OptionsNG my ports.
Diffstat (limited to 'mail/libmapi/Makefile')
-rw-r--r--mail/libmapi/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/mail/libmapi/Makefile b/mail/libmapi/Makefile
index 17f9500c9186..f7b2e130fc2d 100644
--- a/mail/libmapi/Makefile
+++ b/mail/libmapi/Makefile
@@ -36,26 +36,23 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-samba=${LOCALBASE}
-OPTIONS= BOOST "Enable libmapi++ (needs boost)" yes \
- DOXYGEN "Enble building documentation" no
+OPTIONS_DEFINE= BOOST DOXYGEN
+OPTIONS_DEFAULT= BOOST
+BOOST_DESC= Enable libmapi++ (needs boost)
.include <bsd.port.pre.mk>
CONFIGURE_ARGS+= --disable-swig-perl
CONFIGURE_ARGS+= --disable-pymapi
-.if exists(${LOCALBASE}/lib/libboost_thread.so)
-WITH_BOOST=yes
-.endif
-
-.if defined(WITH_BOOST)
+.if ${PORT_OPTIONS:MBOOST} || exists(${LOCALBASE}/lib/libboost_thread.so)
LIB_DEPENDS+= boost_thread.4:${PORTSDIR}/devel/boost-libs
PLIST_SUB+= BOOST=""
.else
PLIST_SUB+= BOOST="@comment "
.endif
-.if defined(WITH_DOXYGEN) || exists(${LOCALBASE}/bin/doxygen)
+.if ${PORT_OPTIONS:MDOXYGEN} || exists(${LOCALBASE}/bin/doxygen)
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
PLIST_SUB+= DOXYGEN=""
.else