aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailfront
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-06-06 23:47:07 +0800
committerantoine <antoine@FreeBSD.org>2014-06-06 23:47:07 +0800
commit20dfee71f42d9ab67155ad823ca86b0dbd35c96f (patch)
tree758840d16c67c4ab3d924b72167a24aeda959e36 /mail/mailfront
parent16a965b78a4837b87c2270c81e12fc7bbd35a5a0 (diff)
downloadfreebsd-ports-gnome-20dfee71f42d9ab67155ad823ca86b0dbd35c96f.tar.gz
freebsd-ports-gnome-20dfee71f42d9ab67155ad823ca86b0dbd35c96f.tar.zst
freebsd-ports-gnome-20dfee71f42d9ab67155ad823ca86b0dbd35c96f.zip
Unbreak, this port needs lua51
Reported by: pkg-fallout PR: ports/190696
Diffstat (limited to 'mail/mailfront')
-rw-r--r--mail/mailfront/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/mail/mailfront/Makefile b/mail/mailfront/Makefile
index d493a0d083cb..6216af9c485f 100644
--- a/mail/mailfront/Makefile
+++ b/mail/mailfront/Makefile
@@ -37,7 +37,7 @@ DOCS= NEWS README TODO *.html
.if ${PORT_OPTIONS:MLUA}
ALL_TARGET+= lua
-USES+= lua
+USES+= lua:51
CFLAGS+= -I${LUA_INCDIR}
CFLAGS_SO+= -L${LUA_LIBDIR}
LDFLAGS+= -L${LUA_LIBDIR}
@@ -56,6 +56,9 @@ do-configure:
${ECHO_CMD} "${BGLIBS_LIB}" > ${WRKSRC}/conf-bglibs
${ECHO_CMD} "${QMAIL_PREFIX}" > ${WRKSRC}/conf-qmail
+post-patch:
+ @${REINPLACE_CMD} 's,-llua,-llua-${LUA_VER},' ${WRKSRC}/Makefile
+
.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}