aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailscanner
diff options
context:
space:
mode:
authorsergei <sergei@FreeBSD.org>2004-02-01 07:43:16 +0800
committersergei <sergei@FreeBSD.org>2004-02-01 07:43:16 +0800
commite2114098ee3d6f87269ca0b2c831f81e6c9d1f1e (patch)
tree601093f944f16e32a3e387f35de843a2a0e270dc /mail/mailscanner
parentf23b245d1fc347a701227fbead5404354871970f (diff)
downloadfreebsd-ports-gnome-e2114098ee3d6f87269ca0b2c831f81e6c9d1f1e.tar.gz
freebsd-ports-gnome-e2114098ee3d6f87269ca0b2c831f81e6c9d1f1e.tar.zst
freebsd-ports-gnome-e2114098ee3d6f87269ca0b2c831f81e6c9d1f1e.zip
- Patch several installed files to respect LOCALBASE [1]
- Add SIZE to distinfo - Bump PORTREVISION [1] PR: ports/61945 [1] Submitted by: maintainer [1]
Diffstat (limited to 'mail/mailscanner')
-rw-r--r--mail/mailscanner/Makefile21
-rw-r--r--mail/mailscanner/distinfo1
-rw-r--r--mail/mailscanner/files/Sophos.install.freebsd8
3 files changed, 23 insertions, 7 deletions
diff --git a/mail/mailscanner/Makefile b/mail/mailscanner/Makefile
index 255b4b65a3ae..7f4e55aab511 100644
--- a/mail/mailscanner/Makefile
+++ b/mail/mailscanner/Makefile
@@ -7,13 +7,13 @@
PORTNAME= MailScanner
PORTVERSION= 4.25.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= http://www.sng.ecs.soton.ac.uk/mailscanner/files/4/tar/
DISTNAME= MailScanner-${PORTVERSION:C/\.([0-9]+)$/-\1/}
MAINTAINER= j.koopmann@seceidos.de
-COMMENT= Powerful virus/spam scanning framework for Sendmail/Exim
+COMMENT= Powerful virus/spam scanning framework for mail gateways
BUILD_DEPENDS= \
${SITE_PERL}/IO/Stringy.pm:${PORTSDIR}/devel/p5-IO-stringy \
@@ -24,7 +24,7 @@ BUILD_DEPENDS= \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
- ${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net/p5-Net-CIDR
+ ${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net/p5-Net-CIDR
RUN_DEPENDS= ${BUILD_DEPENDS} \
${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash2 \
@@ -54,6 +54,12 @@ DOC_FILES= INSTALL INSTALL.FreeBSD INSTALL.OpenBSD README
ETC_FILES= MailScanner.conf filename.rules.conf \
filetype.rules.conf spam.assassin.prefs.conf \
spam.lists.conf virus.scanners.conf
+USRLOCAL_FILES_LIB= \
+ bitdefender-autoupdate f-prot-autoupdate \
+ f-secure-wrapper inoculan-autoupdate \
+ kavdaemonclient-wrapper mcafee-autoupdate \
+ nod32-autoupdate rav-autoupdate \
+ rav-wrapper sophos-autoupdate
do-build:
${PERL} -pi -e \
@@ -92,6 +98,11 @@ do-build:
${PERL} -pi -e \
's,/usr/bin/unzip,${LOCALBASE}/bin/unzip,g;' \
${WRKSRC}/lib/sophos-autoupdate
+.for FILE in ${USRLOCAL_FILES_LIB}
+ ${PERL} -pi -e \
+ 's,/usr/local,${LOCALBASE},g;' \
+ ${WRKSRC}/lib/${FILE}
+.endfor
do-install:
#
@@ -161,6 +172,10 @@ do-install:
${INSTALL_MAN} ${MAN8} ${MAN8PREFIX}/man/man8
# Sophos install script
${INSTALL_SCRIPT} ${FILESDIR}/Sophos.install.freebsd ${DOCSDIR}
+ ${PERL} -pi -e \
+ 's,%%LOCALBASE%%,${LOCALBASE},g; \
+ s,%%PREFIX%%,${PREFIX},g;' \
+ ${DOCSDIR}/Sophos.install.freebsd
.if exists(${PREFIX}/etc/MailScanner/MailScanner.conf)
# Upgrading MailScanner.conf file... Please wait
@${WRKSRC}/bin/upgrade_MailScanner_conf \
diff --git a/mail/mailscanner/distinfo b/mail/mailscanner/distinfo
index f5ff512fdc67..ca2fcd1f45b6 100644
--- a/mail/mailscanner/distinfo
+++ b/mail/mailscanner/distinfo
@@ -1 +1,2 @@
MD5 (MailScanner-4.25-14.tar.gz) = a730889387355d5e215a655a3fc5bc55
+SIZE (MailScanner-4.25-14.tar.gz) = 960107
diff --git a/mail/mailscanner/files/Sophos.install.freebsd b/mail/mailscanner/files/Sophos.install.freebsd
index f1df49606e82..6d4aedfd3b0d 100644
--- a/mail/mailscanner/files/Sophos.install.freebsd
+++ b/mail/mailscanner/files/Sophos.install.freebsd
@@ -1,4 +1,4 @@
-#!/usr/local/bin/bash
+!%%LOCALBASE%%/bin/bash
#
# $Id: Sophos.install,v 1.13.2.3 2003/06/07 17:20:39 jkf Exp $
#
@@ -8,8 +8,8 @@
# and unpacked the Sophos distribution.
# Tweaked for FreeBSD.
-SOPHOS=/usr/local/Sophos
-SCRIPTS=/usr/local/libexec/MailScanner
+SOPHOS=%%LOCALBASE%%/Sophos
+SCRIPTS=%%PREFIX%%/libexec/MailScanner
COMPD=freebsd.elf.tar.Z
DISTRIB=freebsd.elf.tar
@@ -20,7 +20,7 @@ chmod -R go+rX ${SOPHOS}
# Clear out any old libs from /usr/local/lib which is where
# a default SAVI installation will have left them
echo Clearing out old default Sophos installation libraries
-rm -f /usr/local/lib/libsavi.so*
+rm -f %%LOCALBASE%%/lib/libsavi.so*
# Have we got to uncompress the distribution for them?
if [ -f $COMPD ]; then