aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mutt-devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-02-09 23:26:15 +0800
committerkrion <krion@FreeBSD.org>2004-02-09 23:26:15 +0800
commit5a9a7acd8f292b5536d6aa79de33fed0ec1137ef (patch)
treea4510ba36a3c6d0871b1bb7c984602e33f312b83 /mail/mutt-devel
parent775e0eaf326efe0e2df584c294cd906ef3158d37 (diff)
downloadfreebsd-ports-gnome-5a9a7acd8f292b5536d6aa79de33fed0ec1137ef.tar.gz
freebsd-ports-gnome-5a9a7acd8f292b5536d6aa79de33fed0ec1137ef.tar.zst
freebsd-ports-gnome-5a9a7acd8f292b5536d6aa79de33fed0ec1137ef.zip
- Fix the generation of temporary file names by using mktemp
instead of PID - Bump PORTREVISION PR: ports/62569 Submitted by: maintainer
Diffstat (limited to 'mail/mutt-devel')
-rw-r--r--mail/mutt-devel/Makefile1
-rw-r--r--mail/mutt-devel/files/patch-mktemp12
2 files changed, 13 insertions, 0 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 18ffc9338912..8116ea8963af 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -75,6 +75,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.5.6
+PORTREVISION= 1
CATEGORIES+= mail ipv6
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
diff --git a/mail/mutt-devel/files/patch-mktemp b/mail/mutt-devel/files/patch-mktemp
new file mode 100644
index 000000000000..d6c18b85c52d
--- /dev/null
+++ b/mail/mutt-devel/files/patch-mktemp
@@ -0,0 +1,12 @@
+--- muttlib.c.orig Sun Feb 1 18:15:17 2004
++++ muttlib.c Mon Feb 9 08:44:36 2004
+@@ -657,7 +657,8 @@
+
+ void _mutt_mktemp (char *s, const char *src, int line)
+ {
+- snprintf (s, _POSIX_PATH_MAX, "%s/mutt-%s-%d-%d", NONULL (Tempdir), NONULL(Hostname), (int) getpid (), Counter++);
++ snprintf (s, _POSIX_PATH_MAX, "%s/mutt-%s-XXXXXXXX", NONULL(Tempdir), NONULL(Hostname));
++ mktemp (s);
+ dprint (1, (debugfile, "%s:%d: mutt_mktemp returns \"%s\".\n", src, line, s));
+ unlink (s);
+ }